summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorin Cooper-Bennun2016-06-19 00:28:34 +0100
committerTorin Cooper-Bennun2016-06-19 00:28:34 +0100
commit2e17c24fccbbdc2db1e13b0afc515505e1828f4a (patch)
treeb66a641b9b83a33d7dcc74d8fe6b218ebe75891c
downloadaur-pacsize-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24b2e69591ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pacsize-git
+ pkgdesc = Utility that gets the installed size of pacman packages.
+ pkgver = r2.70aab34
+ pkgrel = 1
+ url = https://github.com/TorinCooperBennun/pacsize
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = python-hurry-filesize
+ source = git+https://github.com/TorinCooperBennun/pacsize.git
+ md5sums = SKIP
+
+pkgname = pacsize-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8981770e8e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Torin Cooper-Bennun <torin.cbennun@googlemail.com>
+
+_pkgname='pacsize'
+pkgname="$_pkgname-git"
+pkgver='r2.70aab34'
+pkgrel=1
+pkgdesc='Utility that gets the installed size of pacman packages.'
+arch=('any')
+url='https://github.com/TorinCooperBennun/pacsize'
+license=('GPL')
+depends=('python' 'python-hurry-filesize')
+makedepends=('git')
+source=('git+https://github.com/TorinCooperBennun/pacsize.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ # mkdir -p "$pkgdir/usr/bin"
+ # cp pacsize "$pkgdir/usr/bin/pacsize"
+ install -D pacsize "$pkgdir/usr/bin/pacsize"
+ # chmod +x "$pkgdir/usr/bin/pacsize"
+}