summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2015-07-07 22:15:25 +0100
committerAngelo Theodorou2015-07-07 22:15:25 +0100
commit12a0ea00141e9900781022bb00e90a9647be9cf8 (patch)
tree4bc3bdf6ba1c7dd7cd02b0d8fdfcb4c3ed582425
downloadaur-12a0ea00141e9900781022bb00e90a9647be9cf8.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ce6bd6ffbf4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pacstats-hg
+ pkgdesc = Statistical charts about pacman activity
+ pkgver = 21
+ pkgrel = 1
+ url = http://pacstats.googlecode.com
+ arch = any
+ license = GPL
+ makedepends = mercurial
+ makedepends = gettext
+ depends = pygtk
+ depends = python-matplotlib
+ provides = pacstats
+ conflicts = pacstats
+
+pkgname = pacstats-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d19c2287df7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Angelo Theodorou <encelo@gmail.com>
+pkgname=pacstats-hg
+pkgver=21
+pkgrel=1
+pkgdesc="Statistical charts about pacman activity"
+arch=('any')
+url="http://pacstats.googlecode.com"
+license=('GPL')
+depends=('pygtk' 'python-matplotlib')
+makedepends=('mercurial' 'gettext')
+provides=('pacstats')
+conflicts=('pacstats')
+
+_hgroot=https://pacstats.googlecode.com/hg/
+_hgrepo=pacstats
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to Mercurial server...."
+
+ if [ -d $_hgrepo ] ; then
+ cd $_hgrepo
+ hg pull -u || return 1
+ msg "The local files are updated."
+ else
+ hg clone $_hgroot $_hgrepo || return 1
+ fi
+
+ msg "Mercurial checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_hgrepo-build"
+ cp -r "$srcdir/$_hgrepo" "$srcdir/$_hgrepo-build"
+ cd "$srcdir/$_hgrepo-build"
+
+ # Building and installing
+ python setup.py install --root=$pkgdir --prefix=/usr
+}