summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMusikolo2023-05-24 17:54:42 -0500
committerMusikolo2023-05-24 17:54:42 -0500
commit2a5ed048272316b856d94508212cddd8b3acf6f3 (patch)
tree940e6218d8493f42fcca7a5b14bef3b3bb331bfa
parent21e8c8d1eca2591a98a5ff76cbb25964abe75143 (diff)
downloadaur-2a5ed048272316b856d94508212cddd8b3acf6f3.tar.gz
Add support for aarch64 architecture
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 26 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c809318ffea7..e935e93e0de2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
# Generated by mksrcinfo v8
-# Fri May 19 19:59:41 UTC 2023
+# Wed May 24 22:53:11 UTC 2023
pkgbase = pact-cli-bin
pkgdesc = A standalone client for the Pact Broker and Pactflow.
pkgver = 2.0.1
pkgrel = 1
url = https://github.com/pact-foundation/pact-ruby-standalone
+ arch = aarch64
arch = x86_64
license = MIT
depends = libxcrypt-compat
- source = https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v2.0.1/pact-2.0.1-linux-x86_64.tar.gz
- source = https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v2.0.1/pact-2.0.1-linux-x86_64.tar.gz.checksum
- sha1sums = d04e74baae795fc0a6b59fa64f6282933a1d6211
- sha1sums = 4a9be2da8ef2d4cdab5d1cf86d9ae64101c4fb40
+ source_aarch64 = https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v2.0.1/pact-2.0.1-linux-arm64.tar.gz
+ source_aarch64 = https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v2.0.1/pact-2.0.1-linux-arm64.tar.gz.checksum
+ sha1sums_aarch64 = a209d7c452974b1c74a0135f6657338aee9bb364
+ sha1sums_aarch64 = a6a984c19b6b9d07d7f90cffa6c64572e24a7a56
+ source_x86_64 = https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v2.0.1/pact-2.0.1-linux-x86_64.tar.gz
+ source_x86_64 = https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v2.0.1/pact-2.0.1-linux-x86_64.tar.gz.checksum
+ sha1sums_x86_64 = d04e74baae795fc0a6b59fa64f6282933a1d6211
+ sha1sums_x86_64 = 4a9be2da8ef2d4cdab5d1cf86d9ae64101c4fb40
pkgname = pact-cli-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4d384ea1c913..3925c81c8d59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,29 @@ pkgname=pact-cli-bin
pkgver=2.0.1
pkgdesc="A standalone client for the Pact Broker and Pactflow."
pkgrel=1
-arch=(x86_64)
+arch=(aarch64 x86_64)
url="https://github.com/pact-foundation/pact-ruby-standalone"
license=(MIT)
makedepends=()
depends=(libxcrypt-compat)
options=()
-source=("https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v${pkgver}/pact-${pkgver}-linux-${arch}.tar.gz"
- "https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v${pkgver}/pact-${pkgver}-linux-${arch}.tar.gz.checksum")
-sha1sums=('d04e74baae795fc0a6b59fa64f6282933a1d6211'
- '4a9be2da8ef2d4cdab5d1cf86d9ae64101c4fb40')
+source_aarch64=("https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v${pkgver}/pact-${pkgver}-linux-arm64.tar.gz"
+ "https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v${pkgver}/pact-${pkgver}-linux-arm64.tar.gz.checksum")
+source_x86_64=("https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v${pkgver}/pact-${pkgver}-linux-x86_64.tar.gz"
+ "https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v${pkgver}/pact-${pkgver}-linux-x86_64.tar.gz.checksum")
+sha1sums_aarch64=('a209d7c452974b1c74a0135f6657338aee9bb364'
+ 'a6a984c19b6b9d07d7f90cffa6c64572e24a7a56')
+sha1sums_x86_64=('d04e74baae795fc0a6b59fa64f6282933a1d6211'
+ '4a9be2da8ef2d4cdab5d1cf86d9ae64101c4fb40')
-prepare() {
+prepare_aarch64() {
msg2 "Verifying integrity..."
- cksum -c -a sha1 pact-${pkgver}-linux-${arch}.tar.gz.checksum
+ cksum -c -a sha1 pact-${pkgver}-linux-arm64.tar.gz.checksum
+}
+
+prepare_x86_64() {
+ msg2 "Verifying integrity..."
+ cksum -c -a sha1 pact-${pkgver}-linux-x86_64.tar.gz.checksum
}
package() {