summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMusikolo2023-02-13 16:25:38 -0600
committerMusikolo2023-02-13 16:25:38 -0600
commit42411115fac2517fb6f5c7be43c708b5bee5fd5a (patch)
tree458bfd8647d53f49aada7fd6c6a9517280a68853
downloadaur-42411115fac2517fb6f5c7be43c708b5bee5fd5a.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be34345f2d25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Feb 13 22:20:01 UTC 2023
+pkgbase = pact-cli-bin
+ pkgdesc = A standalone client for the Pact Broker and Pactflow.
+ pkgver = 1.91.0
+ pkgrel = 1
+ url = https://github.com/pact-foundation/pact-ruby-standalone
+ arch = x86_64
+ license = MIT
+ depends = libxcrypt-compat
+ source = https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v1.91.0/pact-1.91.0-linux-x86_64.tar.gz
+ source = https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v1.91.0/pact-1.91.0-linux-x86_64.tar.gz.checksum
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = pact-cli-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f2888c0a494
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+#Maintainer: Musikolo<musikolo {at} hotmail [dot] com>
+pkgname=pact-cli-bin
+pkgver=1.91.0
+pkgdesc="A standalone client for the Pact Broker and Pactflow."
+pkgrel=1
+arch=(x86_64)
+url="https://github.com/pact-foundation/pact-ruby-standalone"
+license=(MIT)
+makedepends=()
+depends=(libxcrypt-compat)
+options=()
+source=("https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v${pkgver}/pact-${pkgver}-linux-${arch}.tar.gz"
+ "https://github.com/pact-foundation/pact-ruby-standalone/releases/download/v${pkgver}/pact-${pkgver}-linux-${arch}.tar.gz.checksum")
+sha1sums=('SKIP' 'SKIP')
+
+prepare() {
+ msg2 "Verifying integrity..."
+ cksum -c -a sha1 pact-${pkgver}-linux-${arch}.tar.gz.checksum
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt"
+ mv "${srcdir}/pact" "${pkgdir}/opt/${pkgname}"
+
+ mkdir -p "${pkgdir}/usr/bin/"
+ cd "${pkgdir}/usr/bin/"
+ for f in ${pkgdir}/opt/${pkgname}/bin/*;
+ do
+ name="$(basename "$f")"
+ ln -s "/opt/${pkgname}/bin/$name" "$name"
+ done
+}