summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorexcalibur12342017-09-07 14:31:39 +0200
committerexcalibur12342017-09-07 14:31:39 +0200
commit3df720bb95bf6d00dc249c953dd1177a7b10816b (patch)
tree80660851e8feed055c536d9608e35265fb1d226a
parent24664e09e2943f7f6707571b719bb11780c69429 (diff)
downloadaur-3df720bb95bf6d00dc249c953dd1177a7b10816b.tar.gz
automatically updating and proper git version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14d86919f5ed..ce2960b49a95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pacui-git
pkgdesc = Bash script providing advanced Pacman and Pacaur/Yaourt functionality in a simple UI
- pkgver = 1.6.1
- pkgrel = 2
+ pkgver = 1.6.1.r52.gf15de67
+ pkgrel = 1
url = https://github.com/excalibur1234/pacui
arch = any
license = GPL3
@@ -17,7 +17,6 @@ pkgbase = pacui-git
optdepends = downgrade: Needed for hidden "downgrade" option.
conflicts = pacui
conflicts = pacli-simple-git
- replaces = pacli-simple-git
source = pacui::git+https://github.com/excalibur1234/pacui.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index da20c0e9802b..e7ba62073106 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,15 @@
_pkgname=pacui
pkgname=$_pkgname-git
-pkgver=1.6.1
-pkgrel=2
+pkgver=1.6.1.r52.gf15de67
+pkgrel=1
pkgdesc="Bash script providing advanced Pacman and Pacaur/Yaourt functionality in a simple UI"
arch=(any)
-url="https://github.com/excalibur1234/pacui"
+url="https://github.com/excalibur1234/$_pkgname"
license=('GPL3')
depends=('expac' 'wget' 'sudo' 'fzf')
makedepends=('git')
conflicts=("$_pkgname" 'pacli-simple-git')
-replaces=('pacli-simple-git')
optdepends=('pacaur: Needed for AUR support. If installed, it gets used by default over Yaourt.'
'yaourt: Needed for AUR support.'
'pacman-mirrors: Needed for Manjaro mirror support'
@@ -20,6 +19,11 @@ optdepends=('pacaur: Needed for AUR support. If installed, it gets used by defau
source=("$_pkgname::git+https://github.com/excalibur1234/$_pkgname.git")
md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
package () {
cd "$srcdir"
install -Dm755 "$srcdir/$_pkgname/pacui" "$pkgdir/usr/bin/pacui"