summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorexcalibur12342017-02-08 21:01:12 +0100
committerexcalibur12342017-02-08 21:01:12 +0100
commit872946fb1176d9d427cc15dd8753e39647e692e9 (patch)
treeebf55cb617f0c3b73360e1cc07e8381fa017e62a
parent73feef0f0b4cacb568d139254e055b16f413c0f6 (diff)
downloadaur-872946fb1176d9d427cc15dd8753e39647e692e9.tar.gz
new test
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f548e54a963..dabf3dab12e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,9 @@ pkgbase = pacui-git
optdepends = yaourt: Needed for AUR support.
optdepends = downgrade: Needed for hidded "downgrade" option.
optdepends = update-notifier: Automatically get notified when updates are available.
- source = git+https://github.com/excalibur1234/pacui
+ provides = pacui
+ conflicts = pacui
+ source = pacui::git+https://github.com/excalibur1234/pacui.git
md5sums = SKIP
pkgname = pacui-git
diff --git a/PKGBUILD b/PKGBUILD
index fa760b7c172e..20e46582439c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
# Maintainer: excalibur1234 @forum.manjaro.org
-pkgname=pacui-git
+_pkgname=pacui
+pkgname=$_pkgname-git
pkgver=1.3
pkgrel=1
pkgdesc="A simple and interative Bash Frontend for Pacman/Pacaur/Yaourt"
arch=(any)
url="https://github.com/excalibur1234/pacui"
license=('GPL3')
-depends=('pacman-mirrorlist'
- 'package-query'
- 'fzf')
+depends=('pacman-mirrorlist' 'package-query' 'fzf')
makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
optdepends=('pacaur: Needed for AUR support. If installed, it gets used by default over Yaourt.'
'yaourt: Needed for AUR support.'
'downgrade: Needed for hidded "downgrade" option.'
'update-notifier: Automatically get notified when updates are available.')
-source=("git+https://github.com/excalibur1234/pacui")
+source=("$_pkgname::git+https://github.com/excalibur1234/$_pkgname.git")
md5sums=('SKIP')
package () {
cd "$srcdir"
- install -Dm755 "$srcdir/pacui/pacui" "$pkgdir/usr/bin/pacui"
+ install -Dm755 "$srcdir/$_pkgname/pacui" "$pkgdir/usr/bin/pacui"
}