summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Gregory2021-05-23 07:49:23 -0700
committerAndrew Gregory2021-05-23 07:52:30 -0700
commit7aaaa85ceffd294e32864736bd970121782e1a53 (patch)
treebcf839db44a97664524b3957b6cfd498325358bf
parent6f23a035c0a48f2b6f69dceac39d1c9b055e671c (diff)
downloadaur-7aaaa85ceffd294e32864736bd970121782e1a53.tar.gz
update for v0.11.0
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD20
3 files changed, 8 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 677e06e5b38a..bb384b66a2ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,16 @@
pkgbase = pacutils-git
pkgdesc = alpm front-end tools
- pkgver = 0.5.0
+ pkgver = 0.11.0
pkgrel = 1
url = https://github.com/andrewgregory/pacutils
arch = i686
arch = x86_64
license = MIT
makedepends = git
- depends = pacman>=5.0
- provides = pacutils=0.5.0
+ depends = pacman>=6.0
+ provides = pacutils=0.11.0
conflicts = pacutils
source = pacutils-git::git://github.com/andrewgregory/pacutils.git
- source = mini.c::git://github.com/andrewgregory/mINI.c.git
- source = globdir.c::git://github.com/andrewgregory/globdir.c.git
- source = tap.c::git://github.com/andrewgregory/tap.c.git
- sha1sums = SKIP
- sha1sums = SKIP
- sha1sums = SKIP
sha1sums = SKIP
pkgname = pacutils-git
-
diff --git a/.gitignore b/.gitignore
index a82141690627..2aa68adacf90 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,4 @@
*.tar.*
-mini.c/
pacutils-git/
pkg/
src/
-tap.c/
diff --git a/PKGBUILD b/PKGBUILD
index 83abfe677d05..ac649dad366e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,27 @@
pkgname=pacutils-git
pkgdesc='alpm front-end tools'
url='https://github.com/andrewgregory/pacutils'
-pkgver=0.5.0
+pkgver=0.11.0
pkgrel=1
arch=('i686' 'x86_64')
-depends=('pacman>=5.0')
+depends=('pacman>=6.0')
makedepends=('git')
conflicts=('pacutils')
provides=("pacutils=$pkgver")
license=('MIT')
-source=("$pkgname::git://github.com/andrewgregory/pacutils.git"
- "mini.c::git://github.com/andrewgregory/mINI.c.git"
- "globdir.c::git://github.com/andrewgregory/globdir.c.git"
- "tap.c::git://github.com/andrewgregory/tap.c.git")
-sha1sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+source=("$pkgname::git://github.com/andrewgregory/pacutils.git")
+sha1sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
git describe --tags | sed 's/^v//; s/-/./g'
}
-prepare() {
- cd "$srcdir/$pkgname"
- git submodule init
- git config submodule.ext/mini.c.url "$srcdir/mini.c"
- git config submodule.ext/globdir.c.url "$srcdir/globdir.c"
- git config submodule.t/tap.c.url "$srcdir/tap.c"
- git submodule update
-}
build() {
cd "$srcdir/$pkgname"
make SYSCONFDIR=/etc LOCALSTATEDIR=/var
+ make doc
}
check() {