summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212022-11-11 09:33:18 +0100
committera8212022-11-11 09:33:18 +0100
commitd145bea6e1026099638e56c7d359d5cbd2c82d58 (patch)
treec8f5b4237f85f0caec734b31bf806a7d9a38a731
parent7aaaa85ceffd294e32864736bd970121782e1a53 (diff)
downloadaur-d145bea6e1026099638e56c7d359d5cbd2c82d58.tar.gz
Adopt and update PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD31
3 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb384b66a2ac..867b351aaa3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = pacutils-git
- pkgdesc = alpm front-end tools
- pkgver = 0.11.0
+ pkgdesc = Helper tools for libalpm
+ pkgver = 0.11.1.r9.gc14c4e1
pkgrel = 1
url = https://github.com/andrewgregory/pacutils
- arch = i686
arch = x86_64
license = MIT
makedepends = git
- depends = pacman>=6.0
- provides = pacutils=0.11.0
+ depends = pacman
+ provides = pacutils
conflicts = pacutils
- source = pacutils-git::git://github.com/andrewgregory/pacutils.git
+ source = git+https://github.com/andrewgregory/pacutils
sha1sums = SKIP
pkgname = pacutils-git
diff --git a/.gitignore b/.gitignore
index 2aa68adacf90..758599962e36 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
*.tar.*
-pacutils-git/
+pacutils/
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index ac649dad366e..216133304353 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,37 @@
+# Maintainer: a821
+# Contributor: agp
+# Contributor: Johannes Löthberg
pkgname=pacutils-git
-pkgdesc='alpm front-end tools'
-url='https://github.com/andrewgregory/pacutils'
-pkgver=0.11.0
+pkgver=0.11.1.r9.gc14c4e1
pkgrel=1
-arch=('i686' 'x86_64')
-depends=('pacman>=6.0')
+pkgdesc='Helper tools for libalpm'
+url='https://github.com/andrewgregory/pacutils'
+arch=('x86_64')
+depends=('pacman')
makedepends=('git')
conflicts=('pacutils')
-provides=("pacutils=$pkgver")
+provides=("pacutils")
license=('MIT')
-source=("$pkgname::git://github.com/andrewgregory/pacutils.git")
+source=("git+${url}")
sha1sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- git describe --tags | sed 's/^v//; s/-/./g'
+ cd pacutils
+ git describe --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
-
build() {
- cd "$srcdir/$pkgname"
- make SYSCONFDIR=/etc LOCALSTATEDIR=/var
- make doc
+ cd pacutils
+ make CFLAGS="$CFLAGS $LDFLAGS" SYSCONFDIR=/etc LOCALSTATEDIR=/var
}
check() {
- cd "$srcdir/$pkgname"
+ cd pacutils
make check
}
package() {
- cd "$srcdir/$pkgname"
+ cd pacutils
make DESTDIR="$pkgdir" PREFIX=/usr install
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}