summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author160R2022-11-22 14:01:15 +0100
committer160R2022-11-22 14:01:15 +0100
commit59473eb8ea2f8ed309bbd059891ceae7a6676d56 (patch)
treee85f33a0ccc867f305a5b000bef65d029376f0d7
parentf1aa07d9dd8d8aa8457f40f6541de692df026e62 (diff)
downloadaur-59473eb8ea2f8ed309bbd059891ceae7a6676d56.tar.gz
bump. version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8175ed44f82c..6e1c04c7a908 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = page-git
- pkgdesc = Advanced, fast pager powered by neovim and inspired by neovim-remote
- pkgver = v3.2.0
+ pkgdesc = Pager powered by neovim and inspired by neovim-remote
+ pkgver = v4.0.0
pkgrel = 1
url = https://github.com/I60R/page
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 67359e5196fc..273bf93398ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=page
pkgname=${_pkgname}-git
pkgrel=1
-pkgver=v3.2.0
-pkgdesc='Advanced, fast pager powered by neovim and inspired by neovim-remote'
+pkgver=v4.0.0
+pkgdesc='Pager powered by neovim and inspired by neovim-remote'
arch=('i686' 'x86_64')
url="https://github.com/I60R/page"
license=('MIT')
@@ -27,15 +27,20 @@ package() {
# Install binaries
install -D -m755 "target/release/page" "$pkgdir/usr/bin/page"
+ install -D -m755 "target/release/nv" "$pkgdir/usr/bin/nv"
# Find last build directory where completions was generated
completions_dir=$(find "target" -name "shell_completions" -type d -printf "%T+\t%p\n" | sort | awk 'NR==1{print $2}')
# Install shell completions
install -D -m644 "$completions_dir/_page" "$pkgdir/usr/share/zsh/site-functions/_page"
- install -D -m644 "$completions_dir/page.bash" "$pkgdir/usr/share/bash-completion/completions/page"
+ install -D -m644 "$completions_dir/page.bash" "$pkgdir/usr/share/bash-completion/completions/page.bash"
install -D -m644 "$completions_dir/page.fish" "$pkgdir/usr/share/fish/completions/page.fish"
+ install -D -m644 "$completions_dir/_nv" "$pkgdir/usr/share/zsh/site-functions/_nv"
+ install -D -m644 "$completions_dir/nv.bash" "$pkgdir/usr/share/bash-completion/completions/nv.bash"
+ install -D -m644 "$completions_dir/nv.fish" "$pkgdir/usr/share/fish/completions/nv.fish"
+
# Install MIT license
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}