summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfutpib2020-01-20 03:06:31 +0300
committerfutpib2020-01-20 03:06:31 +0300
commitaa009391c45ec99294ce9f3eadcdf7e994214e7d (patch)
tree4bc8e712cef699b8cb5cbc3882df79174af417fd
parentd165e9b13a043788bbac275fb93e6656d7e0e71c (diff)
downloadaur-aa009391c45ec99294ce9f3eadcdf7e994214e7d.tar.gz
Add dockerfile to test installation
-rw-r--r--.dockerignore7
-rw-r--r--.gitignore6
-rw-r--r--Dockerfile23
3 files changed, 36 insertions, 0 deletions
diff --git a/.dockerignore b/.dockerignore
new file mode 100644
index 000000000000..7a0fe0b00bf9
--- /dev/null
+++ b/.dockerignore
@@ -0,0 +1,7 @@
+.git/
+**/*
+!**/.gitignore
+!**/.dockerignore
+!**/PKGBUILD
+!**/.SRCINFO
+!**/Dockerfile \ No newline at end of file
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8a658e57fbfb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!.dockerignore
+!PKGBUILD
+!.SRCINFO
+!Dockerfile \ No newline at end of file
diff --git a/Dockerfile b/Dockerfile
new file mode 100644
index 000000000000..4e0347677075
--- /dev/null
+++ b/Dockerfile
@@ -0,0 +1,23 @@
+# This is used only to test that this package builds on a fresh install of Arch Linux
+
+FROM archlinux:20200106
+
+RUN set -xe; \
+ pacman -Syu --noconfirm; \
+ pacman -S --noconfirm sudo base-devel git
+
+RUN useradd -m user
+RUN echo 'user ALL=(ALL) NOPASSWD: ALL' >> /etc/sudoers
+USER user
+
+RUN set -xe; \
+ cd $(mktemp -d); \
+ git clone https://aur.archlinux.org/papeaks-git.git; \
+ cd papeaks-git; \
+ makepkg -si --noconfirm
+
+RUN mkdir /tmp/pkg
+WORKDIR /tmp/pkg
+COPY ./ ./
+
+RUN makepkg -si --noconfirm