summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-28 10:35:09 +0300
committerCaleb Maclennan2020-02-28 10:36:08 +0300
commit4d908380a25af923cf2ababda9dc7d4350bf46c9 (patch)
tree43e0425cf41ee492c30a7fb322ad9f07aa57a4ee
parentf4d7b97a263d8ab3805ba3c54b9d1ab1d78e8234 (diff)
downloadaur-4d908380a25af923cf2ababda9dc7d4350bf46c9.tar.gz
Patch Apache configuration file with correct python path
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc0102d2a567..2d2531553642 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pagure
pkgdesc = A git-centered forge based on python using pygit2
pkgver = 5.8.1
- pkgrel = 0.9
+ pkgrel = 0.10
url = https://pagure.io/pagure
install = pagure.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index c9faf8dbbc29..1b61491f7305 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=pagure
pkgver=5.8.1
-pkgrel=0.9
+pkgrel=0.1O
pkgdesc="A git-centered forge based on python using pygit2"
arch=("any")
url="https://pagure.io/$pkgname"
@@ -65,6 +65,8 @@ sha256sums=('5e150bad0a3f932d265cb59d46c8b6a532be0f757aab695a8c37df3f5f4db687'
prepare() {
cd "$pkgname-$pkgver"
patch -p1 < "../${source[1]##*/}"
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ sed -i -e "s#/usr/lib/pythonX.Y/site-packages#$site_packages#" files/pagure.conf
}
build() {