summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-28 15:35:16 +0300
committerCaleb Maclennan2020-02-28 15:35:51 +0300
commitef8bd3597ffe782faa3d6aa97696f7f3e90aa91f (patch)
treebd5bd49ae12a4eed6903084e827cd86daa77dd84
parent07af56e546f81df085f21b3c42b92055cf61e8d4 (diff)
downloadaur-ef8bd3597ffe782faa3d6aa97696f7f3e90aa91f.tar.gz
Rename script to match upstream docs, add optdepends
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
-rw-r--r--pagure-mariadb.install4
-rw-r--r--pagure-postgresql.install4
-rw-r--r--pagure-sqlite.install4
5 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a593f0e7a2b2..3aa4b7cbc88c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pagure
pkgdesc = A git-centered forge based on python using pygit2
pkgver = 5.8.1
- pkgrel = 0.19
+ pkgrel = 0.20
url = https://pagure.io/pagure
arch = any
license = GPL2
@@ -41,6 +41,7 @@ pkgbase = pagure
depends = python-straight.plugin
depends = python-wtforms
depends = redis
+ optdepends = clamav: Scan uploaded attachments
source = https://releases.pagure.org/pagure/pagure-5.8.1.tar.gz
source = https://src.fedoraproject.org/rpms/pagure/raw/master/f/0501-Revert-Add-a-upper-limit-to-sqlalchemy.patch
sha256sums = 5e150bad0a3f932d265cb59d46c8b6a532be0f757aab695a8c37df3f5f4db687
diff --git a/PKGBUILD b/PKGBUILD
index 353e7adbea67..741f4ae453fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgbase=pagure
pkgname=("$pkgbase" "$pkgbase-apache" "$pkgbase-mariadb" "$pkgbase-postgresql" "$pkgbase-sqlite")
pkgver=5.8.1
-pkgrel=0.19
+pkgrel=0.20
pkgdesc="A git-centered forge based on python using pygit2"
arch=("any")
url="https://pagure.io/$pkgbase"
@@ -48,6 +48,7 @@ depends=('git'
'python'
"${_pydeps[@]/#/python-}"
'redis')
+optdepends=('clamav: Scan uploaded attachments')
makedepends=('python-setuptools')
checkdepends=('python-tox')
source=("https://releases.pagure.org/$pkgbase/$pkgbase-$pkgver.tar.gz"
@@ -92,10 +93,11 @@ package_pagure() {
install -Dm644 -t "$pkgdir/usr/share/doc/$pkgbase/" {README,UPGRADING}.rst
install -Dm644 -T "files/pagure.cfg.sample" "$pkgdir/etc/$pkgbase/pagure.cfg"
install -Dm644 -t "$pkgdir/etc/$pkgbase/" "files/alembic.ini"
- install -Dm644 -t "$pkgdir/usr/share/$pkgbase/" createdb.py
+ install -Dm644 -t "$pkgdir/usr/share/$pkgbase/pagure_createdb.py" createdb.py
install -Dm644 -t "$pkgdir/usr/share/$pkgbase/" files/{api_key_expire_mail,mirror_project_in}.py
install -Dm755 -t "$pkgdir/usr/lib/$pkgbase/" files/{aclchecker,keyhelper}.py
cp -r alembic "$pkgdir/usr/share/$pkgbase/"
+ # TODO: package stuff in doc folder, needs building
}
package_pagure-apache() {
diff --git a/pagure-mariadb.install b/pagure-mariadb.install
index 20fb85478177..bcebf6952767 100644
--- a/pagure-mariadb.install
+++ b/pagure-mariadb.install
@@ -12,7 +12,7 @@ post_install() {
Once configured, populate the database:
- \$ python /usr/share/pagure/createdb.py -c /etc/pagure/pagure.cfg -i /etc/pagure/alembic.ini
+ \$ python /usr/share/pagure/pagure_createdb.py -c /etc/pagure/pagure.cfg -i /etc/pagure/alembic.ini
EOF
}
@@ -20,7 +20,7 @@ post_upgrade() {
cat <<- EOF
Update Pagure database format using:
- \$ python /usr/share/pagure/createdb.py -c /etc/pagure/pagure.cfg
+ \$ python /usr/share/pagure/pagure_createdb.py -c /etc/pagure/pagure.cfg
EOF
}
diff --git a/pagure-postgresql.install b/pagure-postgresql.install
index 3f247f469838..3ba0fec95fa2 100644
--- a/pagure-postgresql.install
+++ b/pagure-postgresql.install
@@ -15,7 +15,7 @@ post_install() {
Once configured, populate the database:
- \$ python /usr/share/pagure/createdb.py -c /etc/pagure/pagure.cfg -i /etc/pagure/alembic.ini
+ \$ python /usr/share/pagure/pagure_createdb.py -c /etc/pagure/pagure.cfg -i /etc/pagure/alembic.ini
EOF
}
@@ -23,7 +23,7 @@ post_upgrade() {
cat <<- EOF
Update Pagure database format using:
- \$ python /usr/share/pagure/createdb.py -c /etc/pagure/pagure.cfg
+ \$ python /usr/share/pagure/pagure_createdb.py -c /etc/pagure/pagure.cfg
EOF
}
diff --git a/pagure-sqlite.install b/pagure-sqlite.install
index 612a3b66c13e..7396a86c164f 100644
--- a/pagure-sqlite.install
+++ b/pagure-sqlite.install
@@ -4,7 +4,7 @@ post_install() {
Configure Pagure in /etc/pagure/pagure.cfg and /etc/pagure/alembic.ini
- \$ python /usr/share/pagure/createdb.py --initial -c /etc/pagure/pagure.cfg -i /etc/pagure/alembic.ini
+ \$ python /usr/share/pagure/pagure_createdb.py --initial -c /etc/pagure/pagure.cfg -i /etc/pagure/alembic.ini
EOF
}
@@ -12,7 +12,7 @@ post_upgrade() {
cat <<- EOF
Update Pagure database format using:
- \$ python /usr/share/pagure/createdb.py -c /etc/pagure/pagure.cfg
+ \$ python /usr/share/pagure/pagure_createdb.py -c /etc/pagure/pagure.cfg
EOF
}