summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody Schafer2019-05-08 14:31:17 -0400
committerCody Schafer2019-05-08 14:31:45 -0400
commit7398fc0f81be5aba0a7b6f9d2a5226ab31bd4fe4 (patch)
treeb2cff33fb6fc53a895846beca34b497f9e018a29
parent105222c853e2ac81a58320cc745650d0a0a4f12c (diff)
downloadaur-7398fc0f81be5aba0a7b6f9d2a5226ab31bd4fe4.tar.gz
fix python issues & add submodule
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--0001-ostra-use-python2.patch22
-rw-r--r--PKGBUILD22
4 files changed, 18 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1457dec1870b..3a08ab904da7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pahole-git
pkgdesc = Various DWARF utils
- pkgver = 1.12.r7.g70ef8c7
- pkgrel = 2
+ pkgver = 1.13.r6.g568dae4
+ pkgrel = 1
url = http://git.kernel.org/?p=devel/pahole/pahole.git;a=summary
arch = i686
arch = x86_64
@@ -10,13 +10,13 @@ pkgbase = pahole-git
makedepends = cmake
makedepends = ninja
depends = elfutils
- depends = python2
+ depends = python
provides = dwarves
provides = pahole
conflicts = dwarves
conflicts = pahole
source = pahole-git::git+https://kernel.googlesource.com/pub/scm/devel/pahole/pahole.git
- source = file://0001-ostra-use-python2.patch
+ source = git+https://github.com/libbpf/libbpf
md5sums = SKIP
md5sums = SKIP
diff --git a/.gitignore b/.gitignore
index fbb3a7499dd8..cef7ab91881d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
pkg
src
pahole-git
+libbpf
diff --git a/0001-ostra-use-python2.patch b/0001-ostra-use-python2.patch
deleted file mode 100644
index e5c8d3a1d7ae..000000000000
--- a/0001-ostra-use-python2.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From a97fc19cd1565a8ed711ce7dbcbd70f9e8c49d85 Mon Sep 17 00:00:00 2001
-From: Cody P Schafer <dev@codyps.com>
-Date: Sun, 4 Nov 2018 23:33:24 -0500
-Subject: [PATCH] ostra: use python2
-
----
- ostra/ostra-cg | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ostra/ostra-cg b/ostra/ostra-cg
-index 0f4009a..917da9f 100755
---- a/ostra/ostra-cg
-+++ b/ostra/ostra-cg
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/env python2
- # ostra-cg - generate callgraphs from encoded trace
- #
- # Arnaldo Carvalho de Melo <acme@redhat.com>
---
-2.19.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 9c66bc29fc31..1284260824bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,28 @@
pkgname=pahole-git
pkgdesc="Various DWARF utils"
-pkgver=1.12.r7.g70ef8c7
-pkgrel=2
+pkgver=1.13.r6.g568dae4
+pkgrel=1
arch=('i686' 'x86_64')
url="http://git.kernel.org/?p=devel/pahole/pahole.git;a=summary"
license=('GPL2')
-depends=('elfutils' 'python2')
+depends=('elfutils' 'python')
makedepends=('git' 'cmake' 'ninja')
provides=('dwarves' 'pahole')
conflicts=('dwarves' 'pahole')
source=(
- $pkgname'::git+https://kernel.googlesource.com/pub/scm/devel/pahole/pahole.git'
- "file://0001-ostra-use-python2.patch"
+ $pkgname::'git+https://kernel.googlesource.com/pub/scm/devel/pahole/pahole.git'
+ 'git+https://github.com/libbpf/libbpf'
)
md5sums=('SKIP' 'SKIP')
prepare() {
- cd "$srcdir/$pkgname"
- patch -Np1 -i "$srcdir/0001-ostra-use-python2.patch"
+ cd "$srcdir"
mkdir -p build
+ cd "$srcdir/$pkgname"
+ git submodule init
+ git config submodule.libbpf.url "$srcdir/libbpf"
+ git submodule update
}
pkgver() {
@@ -29,13 +32,14 @@ pkgver() {
}
build() {
- cd "$srcdir/$pkgname/build"
+ cd "$srcdir/build"
cmake -G Ninja \
-D CMAKE_BUILD_TYPE=Plain \
-D CMAKE_INSTALL_PREFIX=/usr \
-D LIB_INSTALL_DIR=/usr/lib \
- ..
+ ../"$pkgname"
+
ninja -v
}