summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Foran2020-12-15 09:24:14 -0500
committerWill Foran2020-12-15 09:24:14 -0500
commit5635ea959bad0316d7954218636901320c4d47c9 (patch)
tree1c9063b0b0e479682ef881f32f6493f42ab74a0a
parent0beb02c4b3cec1567669880114b4182c34f1c41f (diff)
downloadaur-5635ea959bad0316d7954218636901320c4d47c9.tar.gz
add and use depend: python2-scons
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf2faf8051d4..767147f42b3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Will Foran <will.foran+aur@gmail.com>
-pkgname=paintown-git
+pkgname=paintown-git
pkgver=r7291.ec5824f2
pkgrel=1
pkgdesc="side scrolling fighting game (w/mugen)"
@@ -8,7 +8,7 @@ url="http://paintown.org"
license=('BSD')
groups=()
depends=('freetype2' 'allegro')
-makedepends=('git' 'scons' 'r-tech1')
+makedepends=('git' 'scons' 'r-tech1-git' 'python2-scons')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
@@ -32,7 +32,7 @@ build() {
cd "$srcdir/${pkgname%-git}"
# include freetype2
sed -i -e "s:scons.utils.safeParseConfig(staticEnv, 'freetype-config --libs'):env.Append(CPPPATH = ['/usr/include/freetype2']):" SConstruct
- scons
+ python2 $(which scons)
}
check() {
@@ -45,5 +45,5 @@ package() {
cp "$srcdir/${pkgname%-git}/paintown" paintown-bin
git clone https://github.com/kazzmir/paintown-data.git data
echo "#!/usr/bin/env sh\ncd /usr/share/games/paintown; ./paintown" >> $pkgdir/usr/bin/paintown
- chmod +x paintown-bin $pkgdir/usr/bin/paintown
+ chmod +x paintown-bin $pkgdir/usr/bin/paintown
}