summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArsen Musayelyan2020-02-17 22:11:50 -0800
committerArsen Musayelyan2020-02-17 22:11:50 -0800
commit981e237b7c0daccad013e7670040aa943df31129 (patch)
tree3d9b12d4c905a64b231d0b995d637df4ff815e41
downloadaur-981e237b7c0daccad013e7670040aa943df31129.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6565db079929
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = aptman-git
+ pkgdesc = Changes pacman syntax to be more like APT
+ pkgver = r3.f0ec020
+ pkgrel = 1
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPLv3
+ makedepends = go
+ depends = pak-config
+ source = git+https://gitlab.com/moussaelianarsen/pak.git
+ md5sums = SKIP
+
+pkgname = aptman-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11a65ed50a60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Arsen Musayelyan <moussaelianarsen@gmail.com>
+pkgname=aptman-git
+pkgver=r3.f0ec020
+pkgrel=1
+pkgdesc="Changes pacman syntax to be more like APT"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+license=('GPLv3')
+depends=('pak-config')
+makedepends=('go')
+source=('git+https://gitlab.com/moussaelianarsen/pak.git')
+md5sums=('SKIP')
+
+build() {
+ cd pak
+ make
+}
+
+
+package() {
+ cd pak
+ make DESTDIR="$pkgdir/" installbinonly
+}