summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-10-23 17:23:38 +0200
committerhaawda2019-10-23 17:23:38 +0200
commit39da24b3855c51f2d94b2af36cfe64c9113b5f8e (patch)
tree2ba5389c63942ed728f0aff1d7fdba787ef1d595
parenteb44f0718d8d1bcc062968e6e5d2e6e12fed9133 (diff)
downloadaur-39da24b3855c51f2d94b2af36cfe64c9113b5f8e.tar.gz
bash competion removed
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--remove_bash_completion.patch43
3 files changed, 55 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4066ea1ea9fa..ac75dbe1b47c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pakku-git
pkgdesc = Pacman wrapper with AUR support with latest changes from github repo
pkgver = 0.13.r8.g1f6a5c6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/kitsunyan/pakku
arch = x86_64
license = GPL3
@@ -14,7 +14,9 @@ pkgbase = pakku-git
conflicts = pakku
backup = etc/pakku.conf
source = git+https://github.com/kitsunyan/pakku.git
+ source = remove_bash_completion.patch
sha256sums = SKIP
+ sha256sums = f28b95bf409db284eb5384f0f56ad43b9465e7b7692759d870b28bb4cf45dd17
pkgname = pakku-git
diff --git a/PKGBUILD b/PKGBUILD
index b4f066303c00..7b7e2960ab2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=pakku-git
pkgver=0.13.r8.g1f6a5c6
-pkgrel=1
+pkgrel=2
pkgdesc='Pacman wrapper with AUR support with latest changes from github repo'
arch=('x86_64')
url="https://github.com/kitsunyan/pakku"
@@ -13,15 +13,21 @@ makedepends=('nim' 'git' 'asciidoc')
backup=('etc/pakku.conf')
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-source=("git+https://github.com/kitsunyan/${pkgname%-git}.git")
+source=("git+https://github.com/kitsunyan/${pkgname%-git}.git" remove_bash_completion.patch)
backup=('etc/pakku.conf')
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ 'f28b95bf409db284eb5384f0f56ad43b9465e7b7692759d870b28bb4cf45dd17')
pkgver() {
cd ${pkgname%-git}
git describe --tags|sed 's+-+.r+'|tr - .| cut -c2-
}
+prepare() {
+ cd ${pkgname%-git}
+ git apply "$srcdir"/remove_bash_completion.patch
+}
+
build() {
local addargs=()
grep -Fxq debug <<< "`printf '%s\n' "${options[@]}"`" &&
diff --git a/remove_bash_completion.patch b/remove_bash_completion.patch
new file mode 100644
index 000000000000..373ed41da938
--- /dev/null
+++ b/remove_bash_completion.patch
@@ -0,0 +1,43 @@
+diff --git a/Makefile b/Makefile
+index a4ace3c..41a461f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -7,7 +7,6 @@ MAN_PAGES = \
+ doc/pakku.conf.5
+
+ TARGETS = \
+- completion/bash \
+ completion/zsh \
+ lib/tools \
+ src/pakku \
+@@ -20,8 +19,6 @@ DIST = \
+ COPYING \
+ Makefile \
+ pakku.conf \
+- completion/bash.patch \
+- completion/bash-git.patch \
+ completion/make.sh \
+ completion/zsh.patch \
+ completion/zsh-git.patch \
+@@ -82,13 +79,6 @@ all: \
+ ${TARGETS} \
+ ${TARGETS_NODIST}
+
+-completion/bash: \
+- completion/make.sh \
+- completion/bash.patch \
+- completion/bash-git.patch
+- @echo "GEN: $@"
+- @(cd completion && ./make.sh 'bash')
+-
+ completion/zsh: \
+ completion/make.sh \
+ completion/zsh.patch \
+@@ -143,7 +133,6 @@ define uninstall
+ endef
+
+ install:
+- $(call install,644,'completion/bash','${BASHCOMPLETIONSDIR}/pakku')
+ $(call install,644,'completion/zsh','${ZSHCOMPLETIONSDIR}/_pakku')
+ $(call install,644,'doc/pakku.8','${MANDIR}/man8/pakku.8')
+ $(call install,644,'doc/pakku.conf.5','${MANDIR}/man5/pakku.conf.5')