summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-10-25 16:22:18 +0200
committerhaawda2019-10-25 16:22:18 +0200
commit6a3a5627fb0d0609d5e1574e8f63bed1b27adb39 (patch)
tree81193172282f82ce7bbb9c61a2257e7882f86c2e
parent39da24b3855c51f2d94b2af36cfe64c9113b5f8e (diff)
downloadaur-6a3a5627fb0d0609d5e1574e8f63bed1b27adb39.tar.gz
switch to brunomiguel's repo for now
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--remove_bash_completion.patch43
3 files changed, 9 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac75dbe1b47c..f108492b1d4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = pakku-git
pkgdesc = Pacman wrapper with AUR support with latest changes from github repo
- pkgver = 0.13.r8.g1f6a5c6
- pkgrel = 2
- url = https://github.com/kitsunyan/pakku
+ pkgver = 0.13.r9.ga953c4c
+ pkgrel = 1
+ url = https://github.com/brunomiguel/pakku
arch = x86_64
license = GPL3
makedepends = nim
@@ -13,10 +13,8 @@ pkgbase = pakku-git
provides = pakku
conflicts = pakku
backup = etc/pakku.conf
- source = git+https://github.com/kitsunyan/pakku.git
- source = remove_bash_completion.patch
+ source = git+https://github.com/brunomiguel/pakku.git
sha256sums = SKIP
- sha256sums = f28b95bf409db284eb5384f0f56ad43b9465e7b7692759d870b28bb4cf45dd17
pkgname = pakku-git
diff --git a/PKGBUILD b/PKGBUILD
index 7b7e2960ab2d..b6c4cc182c50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,26 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=pakku-git
-pkgver=0.13.r8.g1f6a5c6
-pkgrel=2
+pkgver=0.13.r9.ga953c4c
+pkgrel=1
pkgdesc='Pacman wrapper with AUR support with latest changes from github repo'
arch=('x86_64')
-url="https://github.com/kitsunyan/pakku"
+url="https://github.com/brunomiguel/pakku"
license=('GPL3')
depends=('libcurl.so' 'git')
makedepends=('nim' 'git' 'asciidoc')
backup=('etc/pakku.conf')
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-source=("git+https://github.com/kitsunyan/${pkgname%-git}.git" remove_bash_completion.patch)
+source=("git+$url.git")
backup=('etc/pakku.conf')
-sha256sums=('SKIP'
- 'f28b95bf409db284eb5384f0f56ad43b9465e7b7692759d870b28bb4cf45dd17')
+sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
git describe --tags|sed 's+-+.r+'|tr - .| cut -c2-
}
-prepare() {
- cd ${pkgname%-git}
- git apply "$srcdir"/remove_bash_completion.patch
-}
-
build() {
local addargs=()
grep -Fxq debug <<< "`printf '%s\n' "${options[@]}"`" &&
diff --git a/remove_bash_completion.patch b/remove_bash_completion.patch
deleted file mode 100644
index 373ed41da938..000000000000
--- a/remove_bash_completion.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff --git a/Makefile b/Makefile
-index a4ace3c..41a461f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -7,7 +7,6 @@ MAN_PAGES = \
- doc/pakku.conf.5
-
- TARGETS = \
-- completion/bash \
- completion/zsh \
- lib/tools \
- src/pakku \
-@@ -20,8 +19,6 @@ DIST = \
- COPYING \
- Makefile \
- pakku.conf \
-- completion/bash.patch \
-- completion/bash-git.patch \
- completion/make.sh \
- completion/zsh.patch \
- completion/zsh-git.patch \
-@@ -82,13 +79,6 @@ all: \
- ${TARGETS} \
- ${TARGETS_NODIST}
-
--completion/bash: \
-- completion/make.sh \
-- completion/bash.patch \
-- completion/bash-git.patch
-- @echo "GEN: $@"
-- @(cd completion && ./make.sh 'bash')
--
- completion/zsh: \
- completion/make.sh \
- completion/zsh.patch \
-@@ -143,7 +133,6 @@ define uninstall
- endef
-
- install:
-- $(call install,644,'completion/bash','${BASHCOMPLETIONSDIR}/pakku')
- $(call install,644,'completion/zsh','${ZSHCOMPLETIONSDIR}/_pakku')
- $(call install,644,'doc/pakku.8','${MANDIR}/man8/pakku.8')
- $(call install,644,'doc/pakku.conf.5','${MANDIR}/man5/pakku.conf.5')