summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-04-08 00:06:02 +0200
committerhaawda2018-04-08 00:06:02 +0200
commit6d3513ea90ddb3889872891bfb4c05d05ebb2b30 (patch)
tree90c3fd7eb4a30c26cc9c4d4460c2132a524c2000
downloadaur-6d3513ea90ddb3889872891bfb4c05d05ebb2b30.tar.gz
initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66840eb65c49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pakku-git
+ pkgdesc = Pacman wrapper with AUR support with latest changes from github repo
+ pkgver = 0.5.1.g769413c
+ pkgrel = 1
+ url = https://github.com/kitsunyan/pakku-git
+ arch = x86_64
+ license = GPL3
+ makedepends = nim
+ makedepends = git
+ depends = libcurl.so
+ depends = git
+ provides = pakku
+ conflicts = pakku
+ backup = etc/pakku.conf
+ source = git+https://github.com/kitsunyan/pakku.git
+ sha256sums = SKIP
+
+pkgname = pakku-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38f45cb6cf12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: kitsunyan <kitsunyan@inbox.ru>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=pakku-git
+pkgver=0.5.1.g769413c
+pkgrel=1
+pkgdesc='Pacman wrapper with AUR support with latest changes from github repo'
+arch=('x86_64')
+url="https://github.com/kitsunyan/$pkgname"
+license=('GPL3')
+depends=('libcurl.so' 'git')
+makedepends=('nim' 'git')
+backup=('etc/pakku.conf')
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+source=("git+https://github.com/kitsunyan/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git describe --tags|sed 's+-+.+g'| cut -c2-
+}
+
+build() {
+ local addargs=()
+ grep -Fxq debug <<< "`printf '%s\n' "${options[@]}"`" &&
+ addargs=(NIM_TARGET='debug' NIM_OPTIMIZE='none')
+
+ cd ${pkgname%-git}
+ make "${addargs[@]}" NIM_CACHE_DIR='../nimcache' PREFIX='/usr'
+}
+
+package() {
+ cd ${pkgname%-git}
+ make PREFIX='/usr' DESTDIR="$pkgdir" install
+}