summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMrViK2018-07-18 00:35:54 +0200
committerMrViK2018-07-18 00:35:54 +0200
commitc6292d47a5bfab1d12f14adb43f9d3d299c53fd7 (patch)
treede8c13f67996704733794a52806b873550d67332
downloadaur-c6292d47a5bfab1d12f14adb43f9d3d299c53fd7.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD29
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c754f3f1d75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pakku-gui-git
+ pkgdesc = GTK frontend for pakku
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://gitlab.com/mrvik/pakku-gui
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = python
+ depends = python-gobject
+ depends = gtk3
+ depends = pakku
+ provides = pakku-gui
+ conflicts = pakku-gui
+ source = git+https://gitlab.com/mrvik/pakku-gui.git
+ sha256sums = SKIP
+
+pkgname = pakku-gui-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4db032ac4cf3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+pakku-gui
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76942a545492
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+_pkgname=pakku-gui
+pkgname=$_pkgname-git
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="GTK frontend for pakku"
+arch=("any") # If pakku and python can be installed, this too
+url="https://gitlab.com/mrvik/$_pkgname"
+license=("GPL2")
+depends=("python" "python-gobject" "gtk3" "pakku")
+makedepends=("git")
+source=("git+https://gitlab.com/mrvik/$_pkgname.git")
+provides=($_pkgname)
+conflicts=($_pkgname)
+sha256sums=('SKIP')
+pkgver(){
+ cd $_pkgname
+ git describe --tags|sed 's+-+.+g'
+}
+
+package(){
+ _libdir=$pkgdir/usr/lib/$_pkgname
+ _applications=$pkgdir/usr/share/applications
+ cd "$srcdir/$_pkgname"
+ mkdir -p "$_libdir" "$_applications" "$pkgdir/usr/bin"
+ cp *.py "$_libdir"
+ cp "$_pkgname.desktop" "$_applications"
+ chmod +x "$_libdir/main.py"
+ ln -s "/usr/lib/$_pkgname/main.py" "$pkgdir/usr/bin/$_pkgname"
+}