summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2019-07-25 14:49:32 +0100
committerWorMzy Tykashi2019-07-25 14:49:32 +0100
commit4ae9ad4e5af681c334c94a2de1e2ec7524140a56 (patch)
treef0f2342d963fdbc9f7713002bef997dc999c1487
parenta2cc36ab149a12dc8d57c5d739c2121b2008ab85 (diff)
downloadaur-4ae9ad4e5af681c334c94a2de1e2ec7524140a56.tar.gz
Update to 28.6.1, gcc9
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
-rw-r--r--mozconfig.in7
3 files changed, 8 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c214678d257..46575d236f53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = palemoon
pkgdesc = Open source web browser based on Firefox focusing on efficiency.
- pkgver = 28.6.0.1
+ pkgver = 28.6.1
pkgrel = 1
url = https://www.palemoon.org/
arch = i686
@@ -16,7 +16,6 @@ pkgbase = palemoon
makedepends = yasm
makedepends = gconf
makedepends = libpulse
- makedepends = gcc8
depends = gtk2
depends = dbus-glib
depends = desktop-file-utils
@@ -26,10 +25,10 @@ pkgbase = palemoon
depends = startup-notification
optdepends = libpulse: PulseAudio audio driver
optdepends = ffmpeg: various video and audio support
- source = git+https://github.com/MoonchildProductions/UXP#tag=PM28.6.0.1_Release
+ source = git+https://github.com/MoonchildProductions/UXP#tag=PM28.6.1_Release
source = mozconfig.in
md5sums = SKIP
- md5sums = 94452a38ce0443eb3741bec9f3c2595b
+ md5sums = f6a92ca06a9ec853396f17610fa0f703
pkgname = palemoon
diff --git a/PKGBUILD b/PKGBUILD
index cffdbb0826c8..4473859a2d57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: ilikenwf
# Contributor: American_Jesus
pkgname=palemoon
-pkgver=28.6.0.1
+pkgver=28.6.1
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=('i686' 'x86_64')
@@ -12,13 +12,13 @@ license=('MPL' 'GPL' 'LGPL')
depends=('gtk2' 'dbus-glib' 'desktop-file-utils' 'libxt' 'mime-types' 'alsa-lib'
'startup-notification')
makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'gconf'
- 'libpulse' 'gcc8')
+ 'libpulse')
optdepends=('libpulse: PulseAudio audio driver'
'ffmpeg: various video and audio support')
source=(git+"https://github.com/MoonchildProductions/UXP#tag=PM${pkgver}_Release"
mozconfig.in)
md5sums=('SKIP'
- '94452a38ce0443eb3741bec9f3c2595b')
+ 'f6a92ca06a9ec853396f17610fa0f703')
prepare() {
sed 's#%SRCDIR%#'"$srcdir"'#g' mozconfig.in > mozconfig
@@ -30,7 +30,7 @@ build() {
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
export MOZCONFIG="$srcdir/mozconfig"
- export CPPFLAGS="$CPPFLAGS -O2"
+ export CPPFLAGS="$CPPFLAGS -O2 -Wno-format-overflow"
python2 mach build
}
diff --git a/mozconfig.in b/mozconfig.in
index ba575ed1434a..e9d2daa09de2 100644
--- a/mozconfig.in
+++ b/mozconfig.in
@@ -1,13 +1,8 @@
-# Once again upstream has failed to keep their code compliant with modern compilers
-# fall back to gcc8 until they fix their code
-export CC=gcc-8
-export CXX=g++-8
-
mk_add_options AUTOCLOBBER=1
mk_add_options MOZ_OBJDIR=%SRCDIR%/pmbuild
ac_add_options --enable-application=palemoon
-ac_add_options --enable-optimize="-O2"
+ac_add_options --enable-optimize="-O2 -Wno-format-overflow"
ac_add_options --enable-official-branding
export MOZILLA_OFFICIAL=1