summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2019-10-29 19:44:47 +0000
committerWorMzy Tykashi2019-10-29 19:44:47 +0000
commit4e699fbab90184f8bc05c4ffea96440a2cee9ff2 (patch)
tree3d0630cc3b10ad8ef365629a09e813307457f7c2
parent41765f0fd0d7d8f33bee32b04e0d1ba51a27f3d9 (diff)
downloadaur-4e699fbab90184f8bc05c4ffea96440a2cee9ff2.tar.gz
Updated to 28.7.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--e31d79e8da99456247df84c2f99ba9083d46efe1.patch57
3 files changed, 5 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f6731de809c..8f321d10bee5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = palemoon
pkgdesc = Open source web browser based on Firefox focusing on efficiency.
- pkgver = 28.7.1
+ pkgver = 28.7.2
pkgrel = 1
url = https://www.palemoon.org/
arch = i686
@@ -25,12 +25,10 @@ pkgbase = palemoon
depends = startup-notification
optdepends = libpulse: PulseAudio audio driver
optdepends = ffmpeg: various video and audio support
- source = git+https://github.com/MoonchildProductions/UXP#tag=PM28.7.1_Release
+ source = git+https://github.com/MoonchildProductions/UXP#tag=PM28.7.2_Release
source = mozconfig.in
- source = e31d79e8da99456247df84c2f99ba9083d46efe1.patch
sha1sums = SKIP
sha1sums = 802731e5af4d117961d3d6fc61bd1e23f69fd384
- sha1sums = dcea3eeeff37747c09d266f7a1af453d81f5f291
pkgname = palemoon
diff --git a/PKGBUILD b/PKGBUILD
index e9c283f4c9bd..a2c71f5b9f9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: ilikenwf
# Contributor: American_Jesus
pkgname=palemoon
-pkgver=28.7.1
+pkgver=28.7.2
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=('i686' 'x86_64')
@@ -16,17 +16,13 @@ makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'gconf'
optdepends=('libpulse: PulseAudio audio driver'
'ffmpeg: various video and audio support')
source=(git+"https://github.com/MoonchildProductions/UXP#tag=PM${pkgver}_Release"
- mozconfig.in
- e31d79e8da99456247df84c2f99ba9083d46efe1.patch)
+ mozconfig.in)
sha1sums=('SKIP'
- '802731e5af4d117961d3d6fc61bd1e23f69fd384'
- 'dcea3eeeff37747c09d266f7a1af453d81f5f291')
+ '802731e5af4d117961d3d6fc61bd1e23f69fd384')
prepare() {
sed 's#%SRCDIR%#'"${srcdir}"'#g' mozconfig.in > mozconfig
sed -i 's#xlocale#locale#' UXP/intl/icu/source/i18n/digitlst.cpp
- cd UXP
- patch -Np1 -i "${srcdir}/e31d79e8da99456247df84c2f99ba9083d46efe1.patch"
}
build() {
diff --git a/e31d79e8da99456247df84c2f99ba9083d46efe1.patch b/e31d79e8da99456247df84c2f99ba9083d46efe1.patch
deleted file mode 100644
index eb265155de8a..000000000000
--- a/e31d79e8da99456247df84c2f99ba9083d46efe1.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From e31d79e8da99456247df84c2f99ba9083d46efe1 Mon Sep 17 00:00:00 2001
-From: "Matt A. Tobin" <email@mattatobin.com>
-Date: Wed, 16 Oct 2019 12:37:07 -0400
-Subject: [PATCH] Fix build errors with newer glibc versions
-
----
- js/src/jsnativestack.cpp | 6 +-----
- tools/profiler/tasktracer/GeckoTaskTracer.cpp | 12 +++---------
- 2 files changed, 4 insertions(+), 14 deletions(-)
-
-diff --git a/js/src/jsnativestack.cpp b/js/src/jsnativestack.cpp
-index 98f8fc7416..94a296bd0e 100644
---- a/js/src/jsnativestack.cpp
-+++ b/js/src/jsnativestack.cpp
-@@ -26,11 +26,7 @@
- # include <sys/syscall.h>
- # include <sys/types.h>
- # include <unistd.h>
--static pid_t
--gettid()
--{
-- return syscall(__NR_gettid);
--}
-+# define gettid() static_cast<pid_t>(syscall(SYS_gettid))
- # endif
-
- #else
-diff --git a/tools/profiler/tasktracer/GeckoTaskTracer.cpp b/tools/profiler/tasktracer/GeckoTaskTracer.cpp
-index ada6956148..36d1bffc38 100644
---- a/tools/profiler/tasktracer/GeckoTaskTracer.cpp
-+++ b/tools/profiler/tasktracer/GeckoTaskTracer.cpp
-@@ -20,22 +20,16 @@
-
- #include <stdarg.h>
-
--// We need a definition of gettid(), but glibc doesn't provide a
-+// We need a definition of gettid(), but older glibc versions don't provide a
- // wrapper for it.
- #if defined(__GLIBC__)
- #include <unistd.h>
- #include <sys/syscall.h>
--static inline pid_t gettid()
--{
-- return (pid_t) syscall(SYS_gettid);
--}
-+#define gettid() static_cast<pid_t>(syscall(SYS_gettid))
- #elif defined(XP_MACOSX)
- #include <unistd.h>
- #include <sys/syscall.h>
--static inline pid_t gettid()
--{
-- return (pid_t) syscall(SYS_thread_selfid);
--}
-+#define gettid() static_cast<pid_t>(syscall(SYS_thread_selfid))
- #elif defined(LINUX)
- #include <sys/types.h>
- pid_t gettid();