summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2018-08-16 20:44:14 +0100
committerWorMzy Tykashi2018-08-16 20:44:14 +0100
commit64dad0fe550a3aff8302d61d51162a139a202a65 (patch)
treedd38fab68ace8c4e6c5089071c16b625bb8af42f
parent318676b0365ee908f084595b1f3648ee75a0384b (diff)
downloadaur-64dad0fe550a3aff8302d61d51162a139a202a65.tar.gz
Updated to 28.0.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD28
-rw-r--r--mozconfig.in44
3 files changed, 29 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59aa46f96145..3729f7e00717 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = palemoon
pkgdesc = Open source web browser based on Firefox focusing on efficiency.
- pkgver = 27.9.4
+ pkgver = 28.0.0
pkgrel = 1
url = https://www.palemoon.org/
arch = i686
@@ -14,6 +14,7 @@ pkgbase = palemoon
makedepends = unzip
makedepends = zip
makedepends = yasm
+ makedepends = gconf
makedepends = libpulse
makedepends = gcc5
depends = gtk2
@@ -24,13 +25,11 @@ pkgbase = palemoon
depends = alsa-lib
depends = startup-notification
optdepends = libpulse: PulseAudio audio driver
- optdepends = hunspell: spell checker and morphological analyzer
- optdepends = hyphen: library for hyphenation and justification
optdepends = ffmpeg: various video and audio support
- source = git+https://github.com/MoonchildProductions/Pale-Moon#tag=27.9.4_Release
+ source = git+https://github.com/MoonchildProductions/UXP#tag=PM28.0.0_Release
source = mozconfig.in
md5sums = SKIP
- md5sums = 3b1d2eff90892a99ff6a0e078b35a839
+ md5sums = 24969676f8b0228701bfb87e05b4526e
pkgname = palemoon
diff --git a/PKGBUILD b/PKGBUILD
index 21b1f18160d8..a8b816970cb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: ilikenwf
# Contributor: American_Jesus
pkgname=palemoon
-pkgver=27.9.4
+pkgver=28.0.0
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=('i686' 'x86_64')
@@ -11,28 +11,26 @@ url="https://www.palemoon.org/"
license=('MPL' 'GPL' 'LGPL')
depends=('gtk2' 'dbus-glib' 'desktop-file-utils' 'libxt' 'mime-types' 'alsa-lib'
'startup-notification')
-makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm'
+makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'gconf'
'libpulse' 'gcc5')
optdepends=('libpulse: PulseAudio audio driver'
- 'hunspell: spell checker and morphological analyzer'
- 'hyphen: library for hyphenation and justification'
'ffmpeg: various video and audio support')
-source=(git+"https://github.com/MoonchildProductions/Pale-Moon#tag=${pkgver}_Release"
+source=(git+"https://github.com/MoonchildProductions/UXP#tag=PM${pkgver}_Release"
mozconfig.in)
md5sums=('SKIP'
- '3b1d2eff90892a99ff6a0e078b35a839')
+ '24969676f8b0228701bfb87e05b4526e')
prepare() {
sed 's#%SRCDIR%#'"$srcdir"'#g' mozconfig.in > mozconfig
- sed -i 's#xlocale#locale#' Pale-Moon/intl/icu/source/i18n/digitlst.cpp
+ sed -i 's#xlocale#locale#' UXP/intl/icu/source/i18n/digitlst.cpp
}
build() {
- cd Pale-Moon
+ cd UXP
# gcc5 doesn't understand the -fno-plt flag, strip it out of C{,XX}FLAGS
export CFLAGS="${CFLAGS//-fno-plt/}"
- export CXXFLAGS="${CFLAGS//-fno-plt/}"
+ export CXXFLAGS="${CXXFLAGS//-fno-plt/}"
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
export MOZCONFIG="$srcdir/mozconfig"
@@ -58,16 +56,6 @@ package() {
install -Dm644 palemoon/browser/icons/mozicon128.png \
"$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
- # use system-provided dictionaries
- rm -rf "$pkgdir"/usr/lib/$pkgname/{dictionaries,hyphenation}
- ln -s /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
- ln -s /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
-
- # avoid duplicate binaries
- # https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- #ln -sf palemoon "$pkgdir/usr/lib/$pkgname/palemoon-bin"
- rm -f "$pkgdir/usr/lib/$pkgname/palemoon-bin"
-
# install desktop file
- install -Dm644 "$srcdir/Pale-Moon/browser/branding/official/palemoon.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/UXP/application/palemoon/branding/official/palemoon.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
}
diff --git a/mozconfig.in b/mozconfig.in
index f8b67e2e234d..7eff8a4799f1 100644
--- a/mozconfig.in
+++ b/mozconfig.in
@@ -1,23 +1,26 @@
-ac_add_options --enable-official-branding
-export MOZILLA_OFFICIAL=1
-
-mk_add_options MOZ_CO_PROJECT=browser
-ac_add_options --enable-application=browser
-
+mk_add_options AUTOCLOBBER=1
mk_add_options MOZ_OBJDIR=%SRCDIR%/pmbuild
+ac_add_options --enable-application=palemoon
-ac_add_options --disable-installer
-ac_add_options --disable-updater
+ac_add_options --enable-optimize="-O2"
-ac_add_options --disable-debug
+ac_add_options --enable-official-branding
+export MOZILLA_OFFICIAL=1
+ac_add_options --enable-default-toolkit=cairo-gtk2
ac_add_options --enable-jemalloc
-#ac_add_options --enable-jemalloc-lib #potentially causes serious regressions
-ac_add_options --with-pthreads
-
ac_add_options --enable-strip
-ac_add_options --enable-optimize="-O2 -msse2 -mfpmath=sse"
-
+ac_add_options --with-pthreads
+
+ac_add_options --disable-tests
+ac_add_options --disable-eme
+ac_add_options --disable-parental-controls
+ac_add_options --disable-accessibility
+ac_add_options --disable-webrtc
+ac_add_options --disable-gamepad
+ac_add_options --disable-necko-wifi
+ac_add_options --disable-updater
+
ac_add_options --x-libraries=/usr/lib
# gcc6 now builds, but explicitly use gcc5 for now. Upstream recommends using gcc4.9 over either but is EOL.
@@ -30,16 +33,3 @@ mk_add_options PYTHON=/usr/bin/python2
# uncomment the following to limit the number of parallel build jobs
# remember to run updpkgsums after, or you'll get a checksum failure
#mk_add_options MOZ_MAKE_FLAGS="-j4"
-
-# disable junk
-ac_add_options --disable-codesighs
-ac_add_options --disable-gamepad
-ac_add_options --disable-logging
-ac_add_options --disable-necko-wifi
-ac_add_options --disable-websms-backend
-
-# enable useful features
-ac_add_options --enable-chrome-format=omni
-ac_add_options --enable-startup-notification
-ac_add_options --enable-shared-js
-ac_add_options --enable-devtools