summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2022-03-18 12:07:50 +0000
committerWorMzy Tykashi2022-03-18 12:07:50 +0000
commit9affba0a3b80b62cfb8f1eca02940cbab562f47d (patch)
tree2077779ed579fc0378f4699dad8ecf0a38f306b8
parent2227e789b8197fb585d7b7f21286fcde4f6d36ed (diff)
downloadaur-9affba0a3b80b62cfb8f1eca02940cbab562f47d.tar.gz
Updated to 30.0.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
-rw-r--r--mozconfig.in4
3 files changed, 31 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cd00cf6fccc..ca5ca48f5953 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = palemoon
pkgdesc = Open source web browser based on Firefox focusing on efficiency.
- pkgver = 29.4.4
+ pkgver = 30.0.0
pkgrel = 1
url = https://www.palemoon.org/
arch = i686
@@ -15,6 +15,7 @@ pkgbase = palemoon
makedepends = yasm
makedepends = gcc10
makedepends = libpulse
+ makedepends = git
depends = gtk2
depends = dbus-glib
depends = desktop-file-utils
@@ -24,15 +25,15 @@ pkgbase = palemoon
depends = startup-notification
optdepends = libpulse: PulseAudio audio driver
optdepends = ffmpeg: various video and audio support
- source = https://archive.palemoon.org/source/palemoon-29.4.4.source.tar.xz
- source = https://archive.palemoon.org/source/palemoon-29.4.4.source.tar.xz.sig
+ source = git+https://repo.palemoon.org/MoonchildProductions/Pale-Moon?signed#commit=5a22267940
+ source = git+https://repo.palemoon.org/MoonchildProductions/GRE
source = mozconfig.in
validpgpkeys = 3DAD8CD107197488D2A2A0BD40481E7B8FCF9CEC
- sha1sums = ace8fffe7d6851c7c0ec2c2555c0b8c19c7611b9
sha1sums = SKIP
- sha1sums = 5fc8e164a8c1731ad2cce6270c9b0e9a5145194c
- sha256sums = 5d81f24fdc7cdb000d6ed5762459eda842b0b1f43fdad3a4be5e8edd5c8f7079
+ sha1sums = SKIP
+ sha1sums = 49ded8cea5fffe4c8c8daec2335249988bc9c149
+ sha256sums = SKIP
sha256sums = SKIP
- sha256sums = a8ded94beaef0dfa4a5d6b109c1a669967cb7d38d4fe70b3a4d7725ef4b47394
+ sha256sums = fe3c49964d7bbebc9fca844e5b4af12c52dac9187b87a98361788cfb6dd65fa7
pkgname = palemoon
diff --git a/PKGBUILD b/PKGBUILD
index 1404d8bb4ea1..6a0247d1ffe6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,10 @@
# Contributor: ilikenwf
# Contributor: American_Jesus
pkgname=palemoon
-pkgver=29.4.4
+_repo=Pale-Moon
+pkgver=30.0.0
+# Commit can be found at https://repo.palemoon.org/MoonchildProductions/Pale-Moon/releases
+_commit=5a22267940
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=('i686' 'x86_64')
@@ -12,29 +15,34 @@ license=('MPL' 'GPL' 'LGPL')
depends=('gtk2' 'dbus-glib' 'desktop-file-utils' 'libxt' 'mime-types' 'alsa-lib'
'startup-notification')
makedepends=('python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'gcc10'
- 'libpulse')
+ 'libpulse' 'git')
optdepends=('libpulse: PulseAudio audio driver'
'ffmpeg: various video and audio support')
-# as of 29.4.1, upstream have switched to unsigned source archives instead of git
-source=("https://archive.palemoon.org/source/palemoon-${pkgver}.source.tar.xz"{,.sig}
+source=(git+"https://repo.palemoon.org/MoonchildProductions/${_repo}?signed#commit=${_commit}"
+ git+"https://repo.palemoon.org/MoonchildProductions/GRE"
mozconfig.in)
validpgpkeys=('3DAD8CD107197488D2A2A0BD40481E7B8FCF9CEC')
-sha1sums=('ace8fffe7d6851c7c0ec2c2555c0b8c19c7611b9'
+sha1sums=('SKIP'
'SKIP'
- '5fc8e164a8c1731ad2cce6270c9b0e9a5145194c')
-sha256sums=('5d81f24fdc7cdb000d6ed5762459eda842b0b1f43fdad3a4be5e8edd5c8f7079'
+ '49ded8cea5fffe4c8c8daec2335249988bc9c149')
+sha256sums=('SKIP'
'SKIP'
- 'a8ded94beaef0dfa4a5d6b109c1a669967cb7d38d4fe70b3a4d7725ef4b47394')
+ 'fe3c49964d7bbebc9fca844e5b4af12c52dac9187b87a98361788cfb6dd65fa7')
prepare() {
sed 's#%SRCDIR%#'"${srcdir}"'#g' mozconfig.in > mozconfig
+ cd ${_repo}
+ git submodule init
+ git config submodule.platform.url "${srcdir}/GRE"
+ git submodule update
}
build() {
+ cd ${_repo}
+
export MOZBUILD_STATE_PATH="${srcdir}/mozbuild"
export MOZCONFIG="${srcdir}/mozconfig"
export CPPFLAGS="${CPPFLAGS} -O2 -Wno-format-overflow"
- cd palemoon-source
./mach build
}
@@ -47,15 +55,15 @@ package() {
ln -s "../lib/${pkgname}/palemoon" "${pkgdir}/usr/bin/palemoon"
# icons
- install -Dm644 palemoon/browser/chrome/icons/default/default16.png \
+ install -Dm644 palemoon/chrome/icons/default/default16.png \
"${pkgdir}/usr/share/icons/hicolor/16x16/apps/${pkgname}.png"
- install -Dm644 palemoon/browser/chrome/icons/default/default32.png \
+ install -Dm644 palemoon/chrome/icons/default/default32.png \
"${pkgdir}/usr/share/icons/hicolor/32x32/apps/${pkgname}.png"
- install -Dm644 palemoon/browser/chrome/icons/default/default48.png \
+ install -Dm644 palemoon/chrome/icons/default/default48.png \
"${pkgdir}/usr/share/icons/hicolor/48x48/apps/${pkgname}.png"
- install -Dm644 palemoon/browser/icons/mozicon128.png \
+ install -Dm644 palemoon/icons/mozicon128.png \
"${pkgdir}/usr/share/icons/hicolor/128x128/apps/${pkgname}.png"
# install desktop file
- install -Dm644 "${srcdir}/palemoon-source/palemoon/branding/official/palemoon.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${srcdir}/${_repo}/other-licenses/branding/palemoon/official/palemoon.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
}
diff --git a/mozconfig.in b/mozconfig.in
index f99befd140b1..cd34cac95c9f 100644
--- a/mozconfig.in
+++ b/mozconfig.in
@@ -6,15 +6,13 @@ export MOZ_PKG_SPECIAL=gtk2
export CC=/usr/bin/gcc-10
export CXX=/usr/bin/g++-10
-ac_add_options --enable-application=palemoon
+ac_add_options --enable-application=browser
ac_add_options --enable-optimize="-O2 -w"
ac_add_options --enable-default-toolkit=cairo-gtk2
ac_add_options --enable-jemalloc
ac_add_options --enable-strip
ac_add_options --enable-devtools
ac_add_options --enable-av1
-ac_add_options --disable-eme
-ac_add_options --disable-webrtc
ac_add_options --disable-gamepad
ac_add_options --disable-tests
ac_add_options --disable-debug