summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2017-01-24 18:32:46 +0000
committerWorMzy Tykashi2017-01-24 18:33:08 +0000
commitdc51ec3814e9d23cf9426d7d56088cea6f33692f (patch)
tree89f52a9963d455ada86a8bae6669d4358ba3dc81
parent256b2cc78e3e3278436ad400df324118f9b0018c (diff)
downloadaur-dc51ec3814e9d23cf9426d7d56088cea6f33692f.tar.gz
Backport fix for sed 4.3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--sed.patch12
3 files changed, 19 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f6490d7dc05..b3e149b31c6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -32,8 +32,10 @@ pkgbase = palemoon
optdepends = gst-plugins-good: h.264 support
source = git+https://github.com/MoonchildProductions/Pale-Moon#tag=27.0.3_Release
source = mozconfig.in
+ source = sed.patch
md5sums = SKIP
md5sums = 17d3e79f16ffa6fe1630849b71fb4709
+ md5sums = 048a6f60fe43e5c3e066fe9181e1a078
pkgname = palemoon
diff --git a/PKGBUILD b/PKGBUILD
index f3c8da503244..6f91995462a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,9 +19,11 @@ optdepends=('libpulse: PulseAudio audio driver'
'gst-libav: h.264 support'
'gst-plugins-good: h.264 support')
source=(git+"https://github.com/MoonchildProductions/Pale-Moon#tag=${pkgver}_Release"
- mozconfig.in)
+ mozconfig.in
+ sed.patch)
md5sums=('SKIP'
- '17d3e79f16ffa6fe1630849b71fb4709')
+ '17d3e79f16ffa6fe1630849b71fb4709'
+ '048a6f60fe43e5c3e066fe9181e1a078')
prepare() {
sed 's#%SRCDIR%#'"$srcdir"'#g' mozconfig.in > mozconfig
@@ -29,6 +31,7 @@ prepare() {
chmod -R +x build/autoconf/* python/*
find . -name '*.sh' -exec chmod +x {} \;
+ patch -p1 -i "$srcdir/sed.patch"
}
build() {
diff --git a/sed.patch b/sed.patch
new file mode 100644
index 000000000000..44b34921f65d
--- /dev/null
+++ b/sed.patch
@@ -0,0 +1,12 @@
+diff -aur a/build/autoconf/icu.m4 b/build/autoconf/icu.m4
+--- a/build/autoconf/icu.m4 2017-01-15 00:31:29.373105596 +0000
++++ b/build/autoconf/icu.m4 2017-01-15 00:31:55.449891004 +0000
+@@ -73,7 +73,7 @@
+ fi
+ fi
+
+- version=`sed -n 's/^[[:space:]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
++ version=`sed -n 's/^[[[:space:]]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
+ if test x"$version" = x; then
+ AC_MSG_ERROR([cannot determine icu version number from uvernum.h header file $lineno])
+ fi