summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 19:32:52 +0200
committerDaniel Nagy2015-06-08 19:32:52 +0200
commit92ed0a6a5fc069f5f99f2b25c1441c3efc5631dc (patch)
treeb381d453c232057bed6b11d1f32363865f9920e5
downloadaur-92ed0a6a5fc069f5f99f2b25c1441c3efc5631dc.tar.gz
import to aur4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05466a65d988
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = firefox-extension-shumway
+ pkgdesc = HTML5 implementation of flash for Firefox
+ pkgver = 0.11.303
+ pkgrel = 1
+ url = https://mozilla.github.io/shumway/
+ arch = any
+ license = MIT
+ makedepends = unzip
+ depends = firefox>=18
+ source = firefox-extension-shumway-0.11.303.xpi::https://mozilla.github.io/shumway/extension/firefox/shumway.xpi
+ sha1sums = SKIP
+
+pkgname = firefox-extension-shumway
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6059990d25db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: GI_Jack <iamjacksemail@hackermail.com>
+# Based on PKGBUILD firefox-extension-httpseverywhere
+
+_plugin_name=shumway
+_plugin_version=20130816
+
+pkgname=firefox-extension-$_plugin_name
+pkgdesc="HTML5 implementation of flash for Firefox"
+pkgver=0.11.303
+pkgrel=1
+arch=('any')
+url="https://mozilla.github.io/shumway/"
+makedepends=( 'unzip' )
+depends=("firefox>=18")
+license=('MIT')
+source=( "$pkgname-$pkgver.xpi::https://mozilla.github.io/shumway/extension/firefox/shumway.xpi" )
+sha1sums=('SKIP') # skip check because this changes rapidly
+
+package(){
+ cd $srcdir
+ emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
+ local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
+ install -d $dstdir
+ cp -r * $dstdir
+ rm -f $dstdir/$pkgname-$pkgver.xpi
+ chmod -R 755 $dstdir
+}
+
+pkgver(){
+ unzip -p $srcdir/$pkgname-$pkgver.xpi content/version.txt | head -1
+}
+