summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPavan Rikhi2018-09-10 12:31:28 -0400
committerPavan Rikhi2018-09-10 12:31:28 -0400
commit03ced8708bb7a58ef2812eca724025533d9bab46 (patch)
tree9fcf98c9c36c5e58cd8dfca325b04a72cd3811a1
parent6ea2ad677c0885a31a9d7655ebcc254e48092f08 (diff)
downloadaur-03ced8708bb7a58ef2812eca724025533d9bab46.tar.gz
Update to v28, Use New UXP Repository
-rw-r--r--PKGBUILD20
-rw-r--r--mozconfig.in40
2 files changed, 31 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd50931ae866..59dac03c30ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Forked from palemoon PKGBUILD by WorMzy Tykashi <wormzy.tykashi@gmail.com>
# Contributor: artiom <a.mv at gmx dot fr>
pkgname=palemoon-git
-pkgver=27.9.0a1+e9a220677
+pkgver=28.1.0a1+eb2016063
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency (git version)"
arch=('i686' 'x86_64')
url="http://www.palemoon.org/"
license=('MPL' 'GPL' 'LGPL')
depends=('gtk2' 'dbus-glib' 'libxt' 'alsa-lib')
-makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'ffmpeg' 'libpulse' 'gcc5')
+makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'ffmpeg' 'libpulse' 'gcc54' 'gconf')
optdepends=('networkmanager: Location detection via available WiFi networks'
'libpulse: PulseAudio audio driver'
'hunspell: spell checker and morphological analyzer'
@@ -17,28 +17,28 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
conflicts=('palemoon')
provides=('palemoon' 'firefox')
install=palemoon.install
-source=(git+"https://github.com/MoonchildProductions/Pale-Moon"
+source=(git+"https://github.com/MoonchildProductions/UXP"
palemoon.desktop
mozconfig.in)
md5sums=('SKIP'
'32231f6e6a532021fd04c6d7b32f4270'
- '0606604e202ac09797247108582e6a9d')
-
+ 'a52adf42c08aef3e48baa167cc751fe6')
+
pkgver() {
- cd Pale-Moon
- echo $(cat browser/config/version.txt)"+"$(git rev-parse --short HEAD)
+ cd UXP
+ echo $(cat application/palemoon/config/version.txt)"+"$(git rev-parse --short HEAD)
}
prepare() {
sed 's#%SRCDIR%#'"$srcdir"'#g' mozconfig.in > mozconfig
- cd Pale-Moon
+ cd UXP
chmod -R +x build/autoconf/* python/*
find . -name '*.sh' -exec chmod +x {} \;
}
-
+
build() {
- cd Pale-Moon
+ cd UXP
export CC=gcc-5
export CXX=g++-5
diff --git a/mozconfig.in b/mozconfig.in
index 5a5b51a2d495..6aac9230479c 100644
--- a/mozconfig.in
+++ b/mozconfig.in
@@ -1,43 +1,45 @@
-## general build setup
+## General Build Setup
+#
+# Since official branding is enabled, we stick pretty close to the suggested
+# mozconfig file at:
+# http://developer.palemoon.org/Developer_Guide:Build_Instructions/Pale_Moon/Linux#head:Mozconfig_Files
+mk_add_options AUTOCLOBBER=1
mk_add_options MOZ_OBJDIR=%SRCDIR%/pmbuild
+ac_add_options --enable-application=palemoon
+
# number of cores your processor has
mk_add_options MOZ_MAKE_FLAGS="-j8"
# let's do some ricing
ac_add_options --enable-optimize="-O2 -msse2 -mfpmath=sse -march=native -mtune=native"
-# strip debugging symbols
-ac_add_options --enable-strip
-ac_add_options --with-pthreads
ac_add_options --enable-official-branding
export MOZILLA_OFFICIAL=1
-mk_add_options MOZ_CO_PROJECT=browser
-ac_add_options --enable-application=browser
+ac_add_options --enable-default-toolkit=cairo-gtk2
+ac_add_options --enable-jemalloc
+ac_add_options --enable-strip
+ac_add_options --with-pthreads
-ac_add_options --disable-installer
+ac_add_options --disable-tests
+ac_add_options --disable-parental-controls
+ac_add_options --disable-accessibility
+ac_add_options --disable-webrtc
+ac_add_options --disable-gamepad
+ac_add_options --disable-necko-wifi
ac_add_options --disable-updater
-ac_add_options --disable-tests
-ac_add_options --disable-mochitests
ac_add_options --disable-debug
ac_add_options --disable-sandbox
ac_add_options --disable-crashreporter
-ac_add_options --disable-accessibility
-ac_add_options --disable-parental-controls
ac_add_options --disable-maintenance-service
-ac_add_options --disable-webrtc
-ac_add_options --disable-websms-backend
-ac_add_options --disable-metro
+ac_add_options --disable-elf-hack
-
-ac_add_options --enable-jemalloc
-ac_add_options --enable-shared-js
ac_add_options --enable-release
ac_add_options --enable-devtools
@@ -48,5 +50,5 @@ ac_add_options --x-libraries=/usr/lib
# Fix GCC Version & Flags
export CC=gcc-5
export CXX=g++-5
-export CXXFLAGS="-fPIC"
-export CFLAGS="-fPIC"
+export CXXFLAGS=${CXXFLAGS//-fno-plt/}
+export CFLAGS=${CFLAGS//-fno-plt/}