summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2022-10-05 22:47:56 +0200
committerMichał Wojdyła2022-10-05 22:47:56 +0200
commit07ee84ebce9c32eef2b23baf8a0740cca2571556 (patch)
tree8abec25cd2f76affcabaa4af96b872ee7437b892
parent7e24dc9f66d1a653fd1a5801e0962021c4dd08c3 (diff)
downloadaur-07ee84ebce9c32eef2b23baf8a0740cca2571556.tar.gz
update to 31.3.0.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--glibc2.36-fix.patch20
-rw-r--r--mozconfig.in5
4 files changed, 12 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db91949d7232..4e94eeccadfa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = palemoon-gtk3
pkgdesc = Open source web browser based on Firefox focusing on efficiency.
- pkgver = 31.2.0.1
+ pkgver = 31.3.0.1
pkgrel = 1
epoch = 1
url = https://www.palemoon.org/
@@ -28,15 +28,13 @@ pkgbase = palemoon-gtk3
optdepends = ffmpeg: various video and audio support
provides = palemoon
conflicts = palemoon
- source = git+https://repo.palemoon.org/MoonchildProductions/Pale-Moon?signed#commit=a70dc0b10c
+ source = git+https://repo.palemoon.org/MoonchildProductions/Pale-Moon?signed#commit=162ae4740d
source = git+https://repo.palemoon.org/MoonchildProductions/UXP
source = mozconfig.in
- source = glibc2.36-fix.patch
validpgpkeys = 3DAD8CD107197488D2A2A0BD40481E7B8FCF9CEC
validpgpkeys = 3059E09144F56804F0FBF4E126B40624BDBFD9F3
sha1sums = SKIP
sha1sums = SKIP
- sha1sums = eb839b808b98106ccd0cbeb6b00ace5b2404db0f
- sha1sums = 21f9ef1825cd26928e23bd95ceac2b23ce9bfa2b
+ sha1sums = 2a006fffaaf9a52fca2bb52ef3eb7c0c0eca7b86
pkgname = palemoon-gtk3
diff --git a/PKGBUILD b/PKGBUILD
index 72cddf1162fe..5e50f4ddd4f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,9 @@ pkgname=palemoon-gtk3
_pkgname=palemoon
_repo=Pale-Moon
epoch=1
-pkgver=31.2.0.1
+pkgver=31.3.0.1
# Commit can be found at https://repo.palemoon.org/MoonchildProductions/Pale-Moon/releases
-_commit=a70dc0b10c
+_commit=162ae4740d
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=('i686' 'x86_64')
@@ -25,14 +25,12 @@ optdepends=('libpulse: PulseAudio audio driver'
'ffmpeg: various video and audio support')
source=(git+"https://repo.palemoon.org/MoonchildProductions/${_repo}?signed#commit=${_commit}"
git+"https://repo.palemoon.org/MoonchildProductions/UXP"
- mozconfig.in
- glibc2.36-fix.patch)
+ mozconfig.in)
validpgpkeys=('3DAD8CD107197488D2A2A0BD40481E7B8FCF9CEC'
'3059E09144F56804F0FBF4E126B40624BDBFD9F3')
sha1sums=('SKIP'
'SKIP'
- 'eb839b808b98106ccd0cbeb6b00ace5b2404db0f'
- '21f9ef1825cd26928e23bd95ceac2b23ce9bfa2b')
+ '2a006fffaaf9a52fca2bb52ef3eb7c0c0eca7b86')
prepare() {
sed 's#%SRCDIR%#'"${srcdir}"'#g' mozconfig.in > mozconfig
@@ -40,7 +38,6 @@ prepare() {
git submodule init
git config submodule.platform.url "${srcdir}/UXP"
git submodule update
- patch -Np1 -i "${srcdir}/glibc2.36-fix.patch"
}
build() {
@@ -71,4 +68,4 @@ package() {
# install desktop file
install -Dm644 "${srcdir}/${_repo}/palemoon/branding/official/palemoon.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
-} \ No newline at end of file
+}
diff --git a/glibc2.36-fix.patch b/glibc2.36-fix.patch
deleted file mode 100644
index 5cb17d153727..000000000000
--- a/glibc2.36-fix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-https://forum.palemoon.org/viewtopic.php?f=62&t=28676
-diff -aur a/platform/ipc/chromium/src/third_party/libevent/arc4random.c b/platform/ipc/chromium/src/third_party/libevent/arc4random.c
---- a/platform/ipc/chromium/src/third_party/libevent/arc4random.c 2022-08-03 10:28:29.353126800 +0100
-+++ b/platform/ipc/chromium/src/third_party/libevent/arc4random.c 2022-08-03 21:16:14.795881259 +0100
-@@ -482,6 +482,7 @@
- #endif
-
- #if defined(_we_have_arc4random_buf) || !defined(XP_SOLARIS)
-+#if (__GLIBC__ <= 2 && __GLIBC_MINOR__ < 36) || !defined(XP_LINUX)
- ARC4RANDOM_EXPORT void
- arc4random_buf(void *_buf, size_t n)
- {
-@@ -496,6 +497,7 @@
- _ARC4_UNLOCK();
- }
- #endif
-+#endif
-
- #ifndef ARC4RANDOM_NOUNIFORM
- /*
diff --git a/mozconfig.in b/mozconfig.in
index 65954abdd0e0..bf03f0e1fb13 100644
--- a/mozconfig.in
+++ b/mozconfig.in
@@ -11,6 +11,9 @@ ac_add_options --enable-jemalloc
ac_add_options --enable-strip
ac_add_options --enable-devtools
ac_add_options --enable-av1
+ac_add_options --enable-phoenix-extensions
+ac_add_options --disable-eme
+ac_add_options --disable-webrtc
ac_add_options --disable-gamepad
ac_add_options --disable-tests
ac_add_options --disable-debug
@@ -26,4 +29,4 @@ mk_add_options PYTHON=/usr/bin/python2
# uncomment the following to limit the number of parallel build jobs
# remember to run updpkgsums after, or you'll get a checksum failure
-#mk_add_options MOZ_MAKE_FLAGS="-j4" \ No newline at end of file
+#mk_add_options MOZ_MAKE_FLAGS="-j4"