summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorotreblan2020-04-22 06:49:38 -0500
committerotreblan2020-04-22 06:49:38 -0500
commitae4f68b6511ca22c5172c8e60118f50848f779c9 (patch)
tree74e739043114603238f7c8108be6a47e92a9babd
downloadaur-ae4f68b6511ca22c5172c8e60118f50848f779c9.tar.gz
First commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD46
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9d6f6e30ffb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = paleofetch-git
+ pkgdesc = neofetch, but written in C
+ pkgver = r17.add6a41
+ pkgrel = 1
+ url = https://github.com/otreblan/paleofetch
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = libx11
+ provides = paleofetch
+ conflicts = paleofetch
+ source = paleofetch-git::git+https://github.com/otreblan/paleofetch.git
+ md5sums = SKIP
+
+pkgname = paleofetch-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6dfb59d8d1ab
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+# create by https://github.com/iamcco/coc-gitignore (Wed Apr 22 2020 06:49:06 GMT-0500 (hora estándar de Perú))
+# ArchLinuxPackages.gitignore:
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+paleofetch-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff40b5d7fba7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Otreblan <otreblain@gmail.com>
+
+pkgname=paleofetch-git
+pkgver=r17.add6a41
+pkgrel=1
+epoch=
+pkgdesc="neofetch, but written in C "
+arch=('x86_64')
+url="https://github.com/otreblan/paleofetch"
+license=('MIT')
+groups=()
+depends=('libx11')
+makedepends=('git' 'cmake')
+checkdepends=()
+optdepends=()
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname}::git+${url}.git")
+md5sums=('SKIP')
+
+prepare() {
+ mkdir -p "${pkgname}/build"
+}
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v-\?//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${pkgname}/build" || exit 1
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_UNITY_BUILD=ON \
+ -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
+ ..
+ make
+}
+
+package() {
+ cd "${pkgname}/build" || exit 1
+ make DESTDIR="$pkgdir/" install
+}