summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-03-21 14:33:37 -0600
committerMark Wagie2024-03-21 14:33:37 -0600
commitf42da7308e8d71c4be7b9d95f0099dec11f969e4 (patch)
tree9731cd5e3f562ed77b03bae4f9daebb7cb1ce801
parentf11b2570f7608b66ce765b1d9f743d99d8796e51 (diff)
downloadaur-f42da7308e8d71c4be7b9d95f0099dec11f969e4.tar.gz
enable LTO
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b34540ac4044..3368acd2c52f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = paleta
pkgdesc = Extract the dominant colors from any image.
pkgver = 0.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/nate-xyz/paleta
arch = x86_64
license = GPL-3.0-or-later
@@ -10,7 +10,6 @@ pkgbase = paleta
makedepends = git
makedepends = meson
depends = libadwaita
- options = !lto
source = git+https://github.com/nate-xyz/paleta.git#commit=d779d2a0393d790586c3f73fb230d029ae406391
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 886fde76aa4c..75828d41ef1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=paleta
pkgver=0.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Extract the dominant colors from any image."
arch=('x86_64')
url="https://github.com/nate-xyz/paleta"
@@ -9,7 +9,7 @@ license=('GPL-3.0-or-later')
depends=('libadwaita')
makedepends=('cargo' 'git' 'meson')
checkdepends=('appstream-glib')
-options=('!lto')
+#options=('!lto')
_commit=d779d2a0393d790586c3f73fb230d029ae406391 # tags/v0.3.1^0
source=("git+https://github.com/nate-xyz/paleta.git#commit=$_commit")
sha256sums=('SKIP')
@@ -27,6 +27,7 @@ prepare() {
}
build() {
+ CFLAGS+=" -ffat-lto-objects"
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
arch-meson "$pkgname" build
@@ -38,5 +39,5 @@ check() {
}
package () {
- meson install -C build --destdir "$pkgdir"
+ meson install -C build --no-rebuild --destdir "$pkgdir"
}