summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weißschuh2012-02-12 14:10:25 +0000
committerThomas Weißschuh2012-02-12 14:10:25 +0000
commitc2c0b7d7d4ea618d442ee319b81229b68bb1378f (patch)
treefd4212a31d2db5a35d6f41a9224abece7ee6d8f2
downloadaur-palm-sdk.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
-rw-r--r--palm-sdk.install38
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42bd671397fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = palm-sdk
+ pkgdesc = WebOS SDK: emulator-image, cmd-line tools, framework, samples, etc.
+ pkgver = 3.0.5
+ pkgrel = 2
+ url = http://developer.palm.com/index.php
+ install = palm-sdk.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = java-environment>=6
+ optdepends = palm-novacom=1.0.80
+ optdepends = virtualbox<=4.1
+ optdepends = virtualbox>=4.0: for emulator usage
+ optdepends = palm-sdk-oldimages: for emulator support of older phones
+ options = !strip
+ source = http://cdn.downloads.palm.com/sdkdownloads/3.0.5.676/sdkBinaries/palm-sdk_3.0.5-svn528736-pho676_i386.deb
+ source = palm-sdk.install
+ sha1sums = 97b862a07e4631f60a28a2bdb4ff9f343be22e07
+ sha1sums = 4e4a352b78d887fce1d195604a434b9bd1d0ba0b
+
+pkgname = palm-sdk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4854eb0927cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Thomas Weißschuh <thomas_weissschuh || lavabit || com>
+# Contributor: Ryan Corder <ryanc@greengrey.org>
+
+pkgname=palm-sdk
+pkgver=3.0.5
+pkgrel=2
+pkgdesc="WebOS SDK: emulator-image, cmd-line tools, framework, samples, etc."
+url="http://developer.palm.com/index.php"
+arch=('i686' 'x86_64')
+license=("custom")
+depends=('java-environment>=6')
+optdepends=('palm-novacom=1.0.80'
+ 'virtualbox<=4.1' 'virtualbox>=4.0: for emulator usage'
+ 'palm-sdk-oldimages: for emulator support of older phones')
+options=(!strip)
+source=("http://cdn.downloads.palm.com/sdkdownloads/${pkgver}.676/sdkBinaries/palm-sdk_${pkgver}-svn528736-pho676_i386.deb"
+ "palm-sdk.install")
+install='palm-sdk.install'
+
+build() {
+
+ cd $srcdir
+
+ tar zxvf ${srcdir}/data.tar.gz -C $pkgdir
+
+ rm -rf ${pkgdir}/usr/local
+ rm -rf ${pkgdir}/usr/share
+
+ mkdir ${pkgdir}/usr/bin
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
+
+ ln -s /opt/PalmSDK/Current/share/documentation/legal/* ${pkgdir}/usr/share/licenses/${pkgname}
+
+ ln -s /opt/PalmSDK/Current/bin/palm-{emulator,generate,install,launch,log,package,worm,run,help} ${pkgdir}/usr/bin/
+ # sdl-config conflicts with binary from 'sdl'
+ #ln -s /opt/PalmPDK/Current/bin/{devprofile,nova-browser,pdk-device-install,pdk-ssh-init,sdl-config} ${pkgdir}/usr/bin/
+}
+sha1sums=('97b862a07e4631f60a28a2bdb4ff9f343be22e07'
+ '4e4a352b78d887fce1d195604a434b9bd1d0ba0b')
diff --git a/palm-sdk.install b/palm-sdk.install
new file mode 100644
index 000000000000..3660c074eacd
--- /dev/null
+++ b/palm-sdk.install
@@ -0,0 +1,38 @@
+# Description: post-install script for palm-sdk
+# Contributor: Ryan Corder <ryanc@greengrey.org>
+#
+
+# arg 1:new package version
+post_install() {
+ echo
+ echo "There are due to filenameclashes no symlinks for PalmPDK in /usr/bin/"
+ echo "You have to either:"
+ echo "Call PalmPDK binaries via absolute calls"
+ echo " e.g /opt/PalmPDK/bin/foo"
+ echo
+ echo "Symlink the binaries you need to /usr/local/bin (maybe change the names)"
+ echo
+ echo "Add /opt/PalmPDK/ to your \$PATH"
+ echo
+ echo "The following entires will likely be required for you to add to"
+ echo "your /etc/hosts file:"
+ echo
+ echo "# Added for palm-sdk"
+ echo "127.0.0.1 qemu"
+ echo "# Added for palmtools"
+ echo "127.0.0.1 device"
+ echo
+ echo "Additionally, you should have this entry in your /etc/hosts file anyway:"
+ echo
+ echo "127.0.0.1 localhost"
+ echo
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*