summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKieran Colford2018-01-03 13:39:17 -0500
committerKieran Colford2018-01-03 13:39:17 -0500
commita3b03bcbdb02b98726c7b5130455ce00e2e0b32a (patch)
tree68f3c6bd67850d010721c171f75af53ef71617c9
downloadaur-a3b03bcbdb02b98726c7b5130455ce00e2e0b32a.tar.gz
intial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b85dbd10530a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pam-cryptsetup-git
+ pkgdesc = A PAM module that allows LUKS-based disk encryption passwords to be kept in sync with account passwords.
+ pkgver = r6.bf0d1ba
+ pkgrel = 1
+ url = https://github.com/google/pam-cryptsetup
+ arch = x86_64
+ arch = i386
+ license = Apache
+ makedepends = git
+ depends = pam
+ depends = cryptsetup
+ depends = glib2
+ provides = pam-cryptsetup
+ conflicts = pam-cryptsetup
+ source = git+https://github.com/google/pam-cryptsetup
+ md5sums = SKIP
+
+pkgname = pam-cryptsetup-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae8345e413e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Kieran Colford <kieran@kcolford.com>
+pkgname=pam-cryptsetup-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=r6.bf0d1ba
+pkgrel=1
+pkgdesc="A PAM module that allows LUKS-based disk encryption passwords to be kept in sync with account passwords."
+arch=('x86_64' 'i386')
+url="https://github.com/google/pam-cryptsetup"
+license=('Apache')
+groups=()
+depends=('pam' 'cryptsetup' 'glib2')
+makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/google/pam-cryptsetup')
+md5sums=('SKIP')
+noextract=()
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ # printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}"
+ make check
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}