summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Kolchenko2021-07-28 18:35:44 +0300
committerAndrey Kolchenko2021-07-28 18:35:44 +0300
commit00a50f8386e9df2246f151c26dc712c697d085e1 (patch)
treed8ce427091b6e305fc2826f10057a9986432d76f
parent83f1792e29409f1a5752924ac5eb5584cf2dbc51 (diff)
downloadaur-00a50f8386e9df2246f151c26dc712c697d085e1.tar.gz
Release version 1.0.8
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD40
3 files changed, 30 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ef98e76aabf..a70c5dd3728a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = pam-python
pkgdesc = Python for PAM
- pkgver = 1.0.7
+ pkgver = 1.0.8
pkgrel = 1
- url = https://github.com/boltgolt/howdy
+ url = http://pam-python.sourceforge.net/
arch = x86_64
- license = MIT
+ license = GNU Affero General Public License
makedepends = python-sphinx
- makedepends = cmake
+ makedepends = make
depends = pam
- depends = python2
- source = https://downloads.sourceforge.net/project/pam-python/pam-python-1.0.7-1/pam-python-1.0.7.tar.gz
- sha256sums = 96ce72fe355b03b87c0eb540ecef06f33738f98f56581e81eb5bffbad1a47e07
+ depends = python
+ source = https://downloads.sourceforge.net/project/pam-python/pam-python-1.0.8-1/pam-python-1.0.8.tar.gz
+ sha256sums = fc69d7717db0509111500a81053487fa7684e1be3b7d0ae2b51970b6fdc918f6
pkgname = pam-python
-
diff --git a/.gitignore b/.gitignore
index 6748987a3d9d..1216353b2c93 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,5 @@
-pkg
-src
-*.tar.gz
-*.zip
-*.tar.xz
-*.patch
-*.dat.bz2 \ No newline at end of file
+/pkg
+/src
+/*.tar.gz
+/*.tar.zst
+
diff --git a/PKGBUILD b/PKGBUILD
index 79c79f1a04a8..32210a43a319 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,39 @@
# Maintainer: boltgolt <boltgolt@gmail.com>
# Maintainer: Kelley McChesney <kelley@kelleymcchesney.us>
+# Maintainer: Andrey Kolchenko <andrey@kolchenko.me>
pkgname=pam-python
-pkgver=1.0.7
+pkgver=1.0.8
pkgrel=1
-pkgdesc="Python for PAM"
+pkgdesc='Python for PAM'
arch=('x86_64')
-url="https://github.com/boltgolt/howdy"
-license=('MIT')
+url='http://pam-python.sourceforge.net/'
+license=('GNU Affero General Public License')
depends=(
- 'pam'
- 'python2'
+ 'pam'
+ 'python'
)
makedepends=(
- 'python-sphinx'
- 'cmake'
+ 'python-sphinx'
+ 'make'
)
source=(
- "https://downloads.sourceforge.net/project/pam-python/pam-python-1.0.7-1/pam-python-1.0.7.tar.gz"
+ "https://downloads.sourceforge.net/project/pam-python/pam-python-${pkgver}-1/pam-python-${pkgver}.tar.gz"
)
-sha256sums=('96ce72fe355b03b87c0eb540ecef06f33738f98f56581e81eb5bffbad1a47e07')
+sha256sums=('fc69d7717db0509111500a81053487fa7684e1be3b7d0ae2b51970b6fdc918f6')
prepare() {
- # Preparing pam-python to be installed
- cd "$srcdir/pam-python-$pkgver"
- sed -i'' 's|#!/usr/bin/python -W default|#!/usr/bin/python2 -W default|g' src/setup.py
- sed -i'' 's|#!/usr/bin/python -W default|#!/usr/bin/python2 -W default|g' src/test.py
- sed -i'' 's|LIBDIR ?= /lib/security|LIBDIR ?= /usr/lib/security|g' src/Makefile
- sed -n '/^License/,/^--$/p' README.txt | grep -v -e '^License' -e '^-\+' > $srcdir/LICENSE
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -n '/^License/,/^--$/p' README.txt | grep -v -e '^License' -e '^-\+' > LICENSE
}
build() {
- # Building pam-python
- cd "$srcdir/pam-python-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgver}"
PREFIX=/usr make
}
package() {
- # Installing pam-python
- cd "$srcdir/pam-python-$pkgver"
- PREFIX=/usr make DESTDIR="$pkgdir/" install
- install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ PREFIX=/usr make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+