summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranklyn Tackitt2019-10-24 09:26:43 -0700
committerFranklyn Tackitt2019-10-24 09:26:43 -0700
commitae38363d61cf54ce38d63101a2df8d8cff9d7528 (patch)
treee24d0d637101bfc205fffbc0c5cf9ab023371f43
downloadaur-ae38363d61cf54ce38d63101a2df8d8cff9d7528.tar.gz
Initial commit - 1.0.6
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD50
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f29de0a088e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pam-python
+ pkgdesc = Python for PAM
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = https://github.com/boltgolt/howdy
+ arch = x86_64
+ license = MIT
+ makedepends = python2-sphinx
+ makedepends = cmake
+ depends = python2
+ source = https://downloads.sourceforge.net/project/pam-python/pam-python-1.0.6-1/pam-python-1.0.6.tar.gz
+ source = https://sourceforge.net/p/pam-python/tickets/_discuss/thread/5dc8cfd5/5839/attachment/pam-python-1.0.6-fedora.patch
+ source = https://sourceforge.net/p/pam-python/tickets/_discuss/thread/5dc8cfd5/5839/attachment/pam-python-1.0.6-gcc8.patch
+ sha256sums = 0ef4dda35da14088afb1640266415730a6e0274bea934917beb5aca90318f853
+ sha256sums = acb9d1b5cf7cad73d5524334b7954431bb9b90f960980378c538907e468c34b5
+ sha256sums = 02dd9a4d8ec921ff9a2408183f290f08102e3f9e0151786ae7220a4d550bfe24
+
+pkgname = pam-python
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6748987a3d9d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg
+src
+*.tar.gz
+*.zip
+*.tar.xz
+*.patch
+*.dat.bz2 \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f3c2d9f1f98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: boltgolt <boltgolt@gmail.com>
+# Maintainer: Kelley McChesney <kelley@kelleymcchesney.us>
+pkgname=pam-python
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="Python for PAM"
+arch=('x86_64')
+url="https://github.com/boltgolt/howdy"
+license=('MIT')
+depends=(
+ 'python2'
+)
+makedepends=(
+ 'python2-sphinx'
+ 'cmake'
+)
+source=(
+ "https://downloads.sourceforge.net/project/pam-python/pam-python-1.0.6-1/pam-python-1.0.6.tar.gz"
+ "https://sourceforge.net/p/pam-python/tickets/_discuss/thread/5dc8cfd5/5839/attachment/pam-python-1.0.6-fedora.patch"
+ "https://sourceforge.net/p/pam-python/tickets/_discuss/thread/5dc8cfd5/5839/attachment/pam-python-1.0.6-gcc8.patch"
+)
+sha256sums=(
+ '0ef4dda35da14088afb1640266415730a6e0274bea934917beb5aca90318f853'
+ 'acb9d1b5cf7cad73d5524334b7954431bb9b90f960980378c538907e468c34b5'
+ '02dd9a4d8ec921ff9a2408183f290f08102e3f9e0151786ae7220a4d550bfe24'
+)
+
+prepare() {
+ # Preparing pam-python to be installed
+ cd pam-python-1.0.6
+ sed -i'' 's|#!/usr/bin/python -W default|#!/usr/bin/python2 -W default|g' src/setup.py
+ sed -i'' 's|#!/usr/bin/python -W default|#!/usr/bin/python2 -W default|g' src/test.py
+ sed -i'' 's|LIBDIR ?= /lib/security|LIBDIR ?= /usr/lib/security|g' src/Makefile
+ sed -i'' 's|sphinx-build|sphinx-build2|g' doc/Makefile
+ patch -p1 < ../pam-python-1.0.6-fedora.patch
+ patch -p1 < ../pam-python-1.0.6-gcc8.patch
+
+ cd ..
+}
+build() {
+ # Building pam-python
+ cd pam-python-1.0.6
+ PREFIX=/usr make
+ cd ..
+}
+package() {
+ # Installing pam-python
+ cd pam-python-1.0.6
+ PREFIX=/usr make DESTDIR="$pkgdir/" install
+}