summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranklyn Tackitt2020-12-03 07:48:25 -0700
committerFranklyn Tackitt2020-12-03 07:48:25 -0700
commitc4ca3af3c44fb85e50cbee0fcde2d770b57728cd (patch)
tree13899e516af4376bf356ab18c90a819ad63b7650
parentaad7b9924ea34153a798b2a84c86f9c1de834886 (diff)
downloadaur-c4ca3af3c44fb85e50cbee0fcde2d770b57728cd.tar.gz
Add LICENSE to PKGBUILD
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 429fe8b3488a..35f501103472 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,7 @@ prepare() {
sed -i'' 's|#!/usr/bin/python -W default|#!/usr/bin/python2 -W default|g' src/setup.py
sed -i'' 's|#!/usr/bin/python -W default|#!/usr/bin/python2 -W default|g' src/test.py
sed -i'' 's|LIBDIR ?= /lib/security|LIBDIR ?= /usr/lib/security|g' src/Makefile
- sed -i'' 's|sphinx-build|sphinx-build|g' doc/Makefile
+ sed -n '/^License/,/^--$/p' README.txt | grep -v -e '^License' -e '^-\+' > $srcdir/LICENSE
}
build() {
@@ -38,4 +38,5 @@ package() {
# Installing pam-python
cd "$srcdir/pam-python-$pkgver"
PREFIX=/usr make DESTDIR="$pkgdir/" install
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}