summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranklyn Tackitt2019-11-15 09:43:07 -0700
committerFranklyn Tackitt2019-11-15 09:43:07 -0700
commitd338646c5f2f6d413ac2e367f38512317b0f6482 (patch)
tree7978a29a7051ac5bbe1bc8feb1904cccc5857d37
parentae38363d61cf54ce38d63101a2df8d8cff9d7528 (diff)
downloadaur-d338646c5f2f6d413ac2e367f38512317b0f6482.tar.gz
pam-python 1.0.7
-rw-r--r--PKGBUILD25
1 files changed, 8 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f3c2d9f1f98..943b4cc3a5eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: boltgolt <boltgolt@gmail.com>
# Maintainer: Kelley McChesney <kelley@kelleymcchesney.us>
pkgname=pam-python
-pkgver=1.0.6
+pkgver=1.0.7
pkgrel=1
pkgdesc="Python for PAM"
arch=('x86_64')
@@ -15,36 +15,27 @@ makedepends=(
'cmake'
)
source=(
- "https://downloads.sourceforge.net/project/pam-python/pam-python-1.0.6-1/pam-python-1.0.6.tar.gz"
- "https://sourceforge.net/p/pam-python/tickets/_discuss/thread/5dc8cfd5/5839/attachment/pam-python-1.0.6-fedora.patch"
- "https://sourceforge.net/p/pam-python/tickets/_discuss/thread/5dc8cfd5/5839/attachment/pam-python-1.0.6-gcc8.patch"
-)
-sha256sums=(
- '0ef4dda35da14088afb1640266415730a6e0274bea934917beb5aca90318f853'
- 'acb9d1b5cf7cad73d5524334b7954431bb9b90f960980378c538907e468c34b5'
- '02dd9a4d8ec921ff9a2408183f290f08102e3f9e0151786ae7220a4d550bfe24'
+ "https://downloads.sourceforge.net/project/pam-python/pam-python-1.0.7-1/pam-python-1.0.7.tar.gz"
)
+sha256sums=('96ce72fe355b03b87c0eb540ecef06f33738f98f56581e81eb5bffbad1a47e07')
prepare() {
# Preparing pam-python to be installed
- cd pam-python-1.0.6
+ cd "$srcdir/pam-python-$pkgver"
sed -i'' 's|#!/usr/bin/python -W default|#!/usr/bin/python2 -W default|g' src/setup.py
sed -i'' 's|#!/usr/bin/python -W default|#!/usr/bin/python2 -W default|g' src/test.py
sed -i'' 's|LIBDIR ?= /lib/security|LIBDIR ?= /usr/lib/security|g' src/Makefile
sed -i'' 's|sphinx-build|sphinx-build2|g' doc/Makefile
- patch -p1 < ../pam-python-1.0.6-fedora.patch
- patch -p1 < ../pam-python-1.0.6-gcc8.patch
-
- cd ..
}
+
build() {
# Building pam-python
- cd pam-python-1.0.6
+ cd "$srcdir/pam-python-$pkgver"
PREFIX=/usr make
- cd ..
}
+
package() {
# Installing pam-python
- cd pam-python-1.0.6
+ cd "$srcdir/pam-python-$pkgver"
PREFIX=/usr make DESTDIR="$pkgdir/" install
}