summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2018-07-01 10:39:39 +0200
committerNicolas Iooss2018-07-01 10:39:39 +0200
commit92a949ffce790983db856cfde856839555a312d2 (patch)
tree4314f447bd742323b63f6f22d9d9c11ead7af5cf
parent98fa95e490fa31f7a5f4fbc1a5047493f44ab087 (diff)
downloadaur-pam-selinux.tar.gz
pam-selinux 1.3.1-1 update
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 22 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4a96b5fcaf..4cc5141ada6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pam-selinux
pkgdesc = SELinux aware PAM (Pluggable Authentication Modules) library
- pkgver = 1.3.0
- pkgrel = 2
+ pkgver = 1.3.1
+ pkgrel = 1
url = http://linux-pam.org
arch = x86_64
groups = selinux
@@ -15,8 +15,8 @@ pkgbase = pam-selinux
depends = libtirpc
depends = pambase-selinux
depends = libselinux
- provides = pam=1.3.0-2
- provides = selinux-pam=1.3.0-2
+ provides = pam=1.3.1-1
+ provides = selinux-pam=1.3.1-1
conflicts = pam
conflicts = selinux-pam
options = !emptydirs
@@ -29,8 +29,11 @@ pkgbase = pam-selinux
backup = etc/security/time.conf
backup = etc/default/passwd
backup = etc/environment
- source = http://linux-pam.org/library/Linux-PAM-1.3.0.tar.bz2
- md5sums = da4b2289b7cfb19583d54e9eaaef1c3a
+ source = https://github.com/linux-pam/linux-pam/releases/download/v1.3.1/Linux-PAM-1.3.1.tar.xz
+ source = https://github.com/linux-pam/linux-pam/releases/download/v1.3.1/Linux-PAM-1.3.1.tar.xz.asc
+ validpgpkeys = 8C6BFD92EE0F42EDF91A6A736D1A7F052E5924BB
+ md5sums = 558ff53b0fc0563ca97f79e911822165
+ md5sums = SKIP
pkgname = pam-selinux
diff --git a/PKGBUILD b/PKGBUILD
index d36b6323f14..09c46ee6685 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,13 @@
# SELinux Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
# SELinux Contributor: Timothée Ravier <tim@siosm.fr>
# SELinux Contributor: Nicky726 <nicky726@gmail.com>
+#
+# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
+# If you want to help keep it up to date, please open a Pull Request there.
pkgname=pam-selinux
-pkgver=1.3.0
-pkgrel=2
+pkgver=1.3.1
+pkgrel=1
pkgdesc="SELinux aware PAM (Pluggable Authentication Modules) library"
arch=('x86_64')
license=('GPL2')
@@ -19,8 +22,14 @@ provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
backup=(etc/security/{access.conf,group.conf,limits.conf,namespace.conf,namespace.init,pam_env.conf,time.conf} etc/default/passwd etc/environment)
groups=('selinux')
-source=(http://linux-pam.org/library/Linux-PAM-$pkgver.tar.bz2)
-md5sums=('da4b2289b7cfb19583d54e9eaaef1c3a')
+source=(https://github.com/linux-pam/linux-pam/releases/download/v$pkgver/Linux-PAM-$pkgver.tar.xz
+ https://github.com/linux-pam/linux-pam/releases/download/v$pkgver/Linux-PAM-$pkgver.tar.xz.asc)
+validpgpkeys=(
+ '8C6BFD92EE0F42EDF91A6A736D1A7F052E5924BB' # Thorsten Kukuk
+)
+
+md5sums=('558ff53b0fc0563ca97f79e911822165'
+ 'SKIP')
options=('!emptydirs')