summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2014-05-22 20:51:02 +0200
committerNicolas Iooss2015-06-27 11:44:55 +0800
commit5f1a7c64eafe6cd91d1f08e9c9de58c7531124f6 (patch)
treef67e86e4c91f7a8700c3bf011b5ba7cc242f9e30
parentd6299929c4b220961423967a1c50e3eba97d9978 (diff)
downloadaur-5f1a7c64eafe6cd91d1f08e9c9de58c7531124f6.tar.gz
pam 1.1.8-4 update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
-rw-r--r--pam-1.1.8-cve-2013-7041.patch52
-rw-r--r--pam-1.1.8-cve-2014-2583.patch56
4 files changed, 135 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96a28c6af7a4..8df33a031616 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pam-selinux
pkgdesc = SELinux aware PAM (Pluggable Authentication Modules) library
pkgver = 1.1.8
- pkgrel = 3
+ pkgrel = 4
url = http://linux-pam.org
arch = i686
arch = x86_64
@@ -16,8 +16,8 @@ pkgbase = pam-selinux
depends = libtirpc
depends = pambase-selinux
depends = libselinux
- provides = pam=1.1.8-3
- provides = selinux-pam=1.1.8-3
+ provides = pam=1.1.8-4
+ provides = selinux-pam=1.1.8-4
conflicts = pam
conflicts = selinux-pam
options = !emptydirs
@@ -33,10 +33,14 @@ pkgbase = pam-selinux
source = https://fedorahosted.org/releases/l/i/linux-pam/Linux-PAM-1.1.8.tar.bz2
source = ftp://ftp.archlinux.org/other/pam_unix2/pam_unix2-2.9.1.tar.bz2
source = pam_unix2-glibc216.patch
+ source = pam-1.1.8-cve-2013-7041.patch
+ source = pam-1.1.8-cve-2014-2583.patch
source = pam_unix2-rm_selinux_check_access.patch
md5sums = 35b6091af95981b1b2cd60d813b5e4ee
md5sums = da6a46e5f8cd3eaa7cbc4fc3a7e2b555
md5sums = dac109f68e04a4df37575fda6001ea17
+ md5sums = 653661bea920de3bb2713bb85b408bc2
+ md5sums = 144ea8e2f9d49a0f4021027ca2c1558f
md5sums = 6a0a6bb6f6f249ef14f6b21ab9880916
pkgname = pam-selinux
diff --git a/PKGBUILD b/PKGBUILD
index df7f6e81cdf8..8f74425a3fb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,11 @@
# Contributor: judd <jvinet@zeroflux.org>
# SELinux Maintainer: Timothée Ravier <tim@siosm.fr>
# SELinux Contributor: Nicky726 <nicky726@gmail.com>
+# SELinux Contributor: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
pkgname=pam-selinux
pkgver=1.1.8
-pkgrel=3
+pkgrel=4
pkgdesc="SELinux aware PAM (Pluggable Authentication Modules) library"
arch=('i686' 'x86_64')
license=('GPL2')
@@ -19,16 +20,32 @@ provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
backup=(etc/security/{access.conf,group.conf,limits.conf,namespace.conf,namespace.init,pam_env.conf,time.conf} etc/default/passwd etc/environment)
groups=('selinux')
source=(https://fedorahosted.org/releases/l/i/linux-pam/Linux-PAM-$pkgver.tar.bz2
- #http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-$pkgver.tar.bz2
ftp://ftp.archlinux.org/other/pam_unix2/pam_unix2-2.9.1.tar.bz2
pam_unix2-glibc216.patch
+ pam-1.1.8-cve-2013-7041.patch
+ pam-1.1.8-cve-2014-2583.patch
pam_unix2-rm_selinux_check_access.patch)
-options=('!emptydirs')
md5sums=('35b6091af95981b1b2cd60d813b5e4ee'
'da6a46e5f8cd3eaa7cbc4fc3a7e2b555'
'dac109f68e04a4df37575fda6001ea17'
+ '653661bea920de3bb2713bb85b408bc2'
+ '144ea8e2f9d49a0f4021027ca2c1558f'
'6a0a6bb6f6f249ef14f6b21ab9880916')
+options=('!emptydirs')
+
+prepare () {
+ cd $srcdir/Linux-PAM-$pkgver
+ # fix CVEs in pam
+ patch -Np1 -i "${srcdir}/pam-1.1.8-cve-2013-7041.patch"
+ patch -Np1 -i "${srcdir}/pam-1.1.8-cve-2014-2583.patch"
+
+ # fix pam_unix2 building
+ cd $srcdir/pam_unix2-2.9.1
+ patch -Np1 -i "${srcdir}/pam_unix2-glibc216.patch"
+ patch -Np1 -i "${srcdir}/pam_unix2-rm_selinux_check_access.patch"
+}
+
build() {
cd $srcdir/Linux-PAM-$pkgver
./configure --libdir=/usr/lib --sbindir=/usr/bin --disable-db \
@@ -36,9 +53,6 @@ build() {
make
cd $srcdir/pam_unix2-2.9.1
- patch -Np1 -i ../pam_unix2-glibc216.patch
- patch -Np1 -i ../pam_unix2-rm_selinux_check_access.patch
-
# modify flags to build against the pam compiled here, not a system lib.
./configure \
CFLAGS="$CFLAGS -I$srcdir/Linux-PAM-$pkgver/libpam/include/" \
diff --git a/pam-1.1.8-cve-2013-7041.patch b/pam-1.1.8-cve-2013-7041.patch
new file mode 100644
index 000000000000..96fa9160bff9
--- /dev/null
+++ b/pam-1.1.8-cve-2013-7041.patch
@@ -0,0 +1,52 @@
+From 57a1e2b274d0a6376d92ada9926e5c5741e7da20 Mon Sep 17 00:00:00 2001
+From: "Dmitry V. Levin" <ldv@altlinux.org>
+Date: Fri, 24 Jan 2014 22:18:32 +0000
+Subject: [PATCH] pam_userdb: fix password hash comparison
+
+Starting with commit Linux-PAM-0-77-28-g0b3e583 that introduced hashed
+passwords support in pam_userdb, hashes are compared case-insensitively.
+This bug leads to accepting hashes for completely different passwords in
+addition to those that should be accepted.
+
+Additionally, commit Linux-PAM-1_1_6-13-ge2a8187 that added support for
+modern password hashes with different lengths and settings, did not
+update the hash comparison accordingly, which leads to accepting
+computed hashes longer than stored hashes when the latter is a prefix
+of the former.
+
+* modules/pam_userdb/pam_userdb.c (user_lookup): Reject the computed
+hash whose length differs from the stored hash length.
+Compare computed and stored hashes case-sensitively.
+Fixes CVE-2013-7041.
+
+Bug-Debian: http://bugs.debian.org/731368
+---
+ modules/pam_userdb/pam_userdb.c | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/modules/pam_userdb/pam_userdb.c b/modules/pam_userdb/pam_userdb.c
+index de8b5b1..ff040e6 100644
+--- a/modules/pam_userdb/pam_userdb.c
++++ b/modules/pam_userdb/pam_userdb.c
+@@ -222,12 +222,15 @@ user_lookup (pam_handle_t *pamh, const char *database, const char *cryptmode,
+ } else {
+ cryptpw = crypt (pass, data.dptr);
+
+- if (cryptpw) {
+- compare = strncasecmp (data.dptr, cryptpw, data.dsize);
++ if (cryptpw && strlen(cryptpw) == (size_t)data.dsize) {
++ compare = memcmp(data.dptr, cryptpw, data.dsize);
+ } else {
+ compare = -2;
+ if (ctrl & PAM_DEBUG_ARG) {
+- pam_syslog(pamh, LOG_INFO, "crypt() returned NULL");
++ if (cryptpw)
++ pam_syslog(pamh, LOG_INFO, "lengths of computed and stored hashes differ");
++ else
++ pam_syslog(pamh, LOG_INFO, "crypt() returned NULL");
+ }
+ };
+
+--
+1.8.3.1
+
diff --git a/pam-1.1.8-cve-2014-2583.patch b/pam-1.1.8-cve-2014-2583.patch
new file mode 100644
index 000000000000..f2aa2de8cba5
--- /dev/null
+++ b/pam-1.1.8-cve-2014-2583.patch
@@ -0,0 +1,56 @@
+From 9dcead87e6d7f66d34e7a56d11a30daca367dffb Mon Sep 17 00:00:00 2001
+From: "Dmitry V. Levin" <ldv@altlinux.org>
+Date: Wed, 26 Mar 2014 22:17:23 +0000
+Subject: [PATCH] pam_timestamp: fix potential directory traversal issue
+ (ticket #27)
+
+pam_timestamp uses values of PAM_RUSER and PAM_TTY as components of
+the timestamp pathname it creates, so extra care should be taken to
+avoid potential directory traversal issues.
+
+* modules/pam_timestamp/pam_timestamp.c (check_tty): Treat
+"." and ".." tty values as invalid.
+(get_ruser): Treat "." and ".." ruser values, as well as any ruser
+value containing '/', as invalid.
+
+Fixes CVE-2014-2583.
+
+Reported-by: Sebastian Krahmer <krahmer@suse.de>
+---
+ modules/pam_timestamp/pam_timestamp.c | 13 ++++++++++++-
+ 1 file changed, 12 insertions(+), 1 deletion(-)
+
+diff --git a/modules/pam_timestamp/pam_timestamp.c b/modules/pam_timestamp/pam_timestamp.c
+index 5193733..b3f08b1 100644
+--- a/modules/pam_timestamp/pam_timestamp.c
++++ b/modules/pam_timestamp/pam_timestamp.c
+@@ -158,7 +158,7 @@ check_tty(const char *tty)
+ tty = strrchr(tty, '/') + 1;
+ }
+ /* Make sure the tty wasn't actually a directory (no basename). */
+- if (strlen(tty) == 0) {
++ if (!strlen(tty) || !strcmp(tty, ".") || !strcmp(tty, "..")) {
+ return NULL;
+ }
+ return tty;
+@@ -243,6 +243,17 @@ get_ruser(pam_handle_t *pamh, char *ruserbuf, size_t ruserbuflen)
+ if (pwd != NULL) {
+ ruser = pwd->pw_name;
+ }
++ } else {
++ /*
++ * This ruser is used by format_timestamp_name as a component
++ * of constructed timestamp pathname, so ".", "..", and '/'
++ * are disallowed to avoid potential path traversal issues.
++ */
++ if (!strcmp(ruser, ".") ||
++ !strcmp(ruser, "..") ||
++ strchr(ruser, '/')) {
++ ruser = NULL;
++ }
+ }
+ if (ruser == NULL || strlen(ruser) >= ruserbuflen) {
+ *ruserbuf = '\0';
+--
+1.8.3.1
+