summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Pigott2022-05-02 22:29:39 -0700
committerRonan Pigott2022-05-02 22:29:39 -0700
commit09e21e29ada4e88c955befca4ae211b3654f5a05 (patch)
treed896f291b2cb87b67c6575e33a2063cb89150e62
downloadaur-09e21e29ada4e88c955befca4ae211b3654f5a05.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cf1944d40eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pam-ssh-add
+ pkgdesc = Standalone pam_ssh_add plugin from cockpit
+ pkgver = 268.1
+ pkgrel = 1
+ url = https://cockpit-project.org/
+ arch = x86_64
+ license = LGPL
+ makedepends = pam
+ depends = pam
+ source = https://github.com/cockpit-project/cockpit/releases/download/268.1/cockpit-268.1.tar.xz
+ sha256sums = 01baf9a92e5d6f67eb4dcd7b9803192f27ab58b18e9bea5b5acad433b50e7a08
+
+pkgname = pam-ssh-add
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..817f012f04b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ronan Pigott <rpigott@berkeley.edu>
+
+pkgname=pam-ssh-add
+pkgver=268.1
+pkgrel=1
+pkgdesc='Standalone pam_ssh_add plugin from cockpit'
+arch=('x86_64')
+url='https://cockpit-project.org/'
+license=(LGPL)
+makedepends=(pam)
+depends=(pam)
+source=("https://github.com/cockpit-project/cockpit/releases/download/$pkgver/cockpit-$pkgver.tar.xz")
+sha256sums=('01baf9a92e5d6f67eb4dcd7b9803192f27ab58b18e9bea5b5acad433b50e7a08')
+
+build() {
+ cd cockpit-$pkgver
+ ./configure --prefix=/usr --disable-pcp
+ make pam_ssh_add.so doc/man/pam_ssh_add.8
+}
+
+package() {
+ cd "cockpit-$pkgver"
+ install -Dm755 pam_ssh_add.so -t "$pkgdir/usr/lib/security/"
+ install -Dm755 doc/man/pam_ssh_add.8 -t "$pkgdir/usr/share/man/man8/"
+}