summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2021-08-21 18:20:04 +0200
committerJoan Bruguera2021-08-21 18:20:04 +0200
commit664e09b1f766bc5c0c021c551a1eafaa955dbe84 (patch)
treee0747069dcd4f35545123fac0b6ddd42feb1fdea
downloadaur-664e09b1f766bc5c0c021c551a1eafaa955dbe84.tar.gz
Initial commit.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
-rwxr-xr-xinstall.sh7
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef3f25cd4f01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pam-tmpdir
+ pkgdesc = PAM module for creating safe per-user temporary directories
+ pkgver = 0.09
+ pkgrel = 1
+ url = https://tracker.debian.org/pkg/pam-tmpdir
+ install = install.sh
+ arch = x86_64
+ license = GPL2
+ depends = pam
+ source = http://deb.debian.org/debian/pool/main/p/pam-tmpdir/pam-tmpdir_0.09.tar.gz
+ sha256sums = 3176b5098e9a943f3713f43e3099acbfc35a22659dd293c929977fee76dee09f
+
+pkgname = pam-tmpdir
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..831b2f5167a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
+pkgname=pam-tmpdir
+pkgver=0.09
+pkgrel=1
+pkgdesc="PAM module for creating safe per-user temporary directories"
+arch=(x86_64)
+url="https://tracker.debian.org/pkg/pam-tmpdir"
+license=('GPL2')
+depends=(pam)
+source=("http://deb.debian.org/debian/pool/main/p/$pkgname/${pkgname}_${pkgver}.tar.gz")
+sha256sums=(3176b5098e9a943f3713f43e3099acbfc35a22659dd293c929977fee76dee09f)
+install=install.sh
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ autoreconf -fiv
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
diff --git a/install.sh b/install.sh
new file mode 100755
index 000000000000..96f1722e9d5c
--- /dev/null
+++ b/install.sh
@@ -0,0 +1,7 @@
+#!/usr/bin/env sh
+
+post_install() {
+ echo 'To enable, add the following line to the end of /etc/pam.d/system-login:'
+ echo ' session optional pam_tmpdir.so'
+}
+