summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Redden2015-06-16 10:50:51 -0400
committerChris Redden2015-06-16 10:50:51 -0400
commit488ca9a06e7c300f63cb82d6ae4e19c12f09d8b6 (patch)
treeedc0dce8fa95ed7a139415d917467b6da7f9f303
downloadaur-488ca9a06e7c300f63cb82d6ae4e19c12f09d8b6.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD50
-rw-r--r--pam_abl.install11
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82eba6a791d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pam_abl
+ pkgdesc = Automated blacklisting on repeated failed authentication attempts
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = http://pam-abl.sourceforge.net/
+ install = pam_abl.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = asciidoc
+ makedepends = cmake
+ depends = db
+ depends = pam
+ source = http://downloads.sourceforge.net/pam-abl/pam-abl-0.6.0.tar.gz
+ md5sums = 62e02b88cf2da09eeea101a99f69f1ee
+
+pkgname = pam_abl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5892cb61aa7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+## Contributor: quantax -- contact via Arch Linux forum or AUR
+## Contributor: Michal Krenek <mikos@sg1.cz>
+## Contributor: redden0t8 -- contact via Arch Linux forums or AUR
+
+pkgname=pam_abl
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Automated blacklisting on repeated failed authentication attempts"
+arch=('i686' 'x86_64')
+url="http://pam-abl.sourceforge.net/"
+license=('GPL')
+depends=(db pam)
+makedepends=(asciidoc cmake)
+source=(http://downloads.sourceforge.net/pam-abl/pam-abl-$pkgver.tar.gz)
+md5sums=('62e02b88cf2da09eeea101a99f69f1ee')
+install="pam_abl.install"
+
+build() {
+ cd "$srcdir"
+
+ # configure
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+
+ # build binaries
+ make || return 1
+
+ # generate documentation
+ cd doc
+ sh generate.sh
+ cd ..
+}
+
+package() {
+ # install binaries
+ make install DESTDIR="$pkgdir/"
+
+ # install example configuration
+ install --mode=0644 -D -- conf/pam_abl.conf \
+ "$pkgdir/etc/security/pam_abl.conf.example"
+
+ #install documentation
+ install --mode=0644 -D -- doc/pam_abl.1 \
+ "$pkgdir/usr/share/man/man1/pam_abl.1"
+ install --mode=0644 -D -- doc/pam_abl.8 \
+ "$pkgdir/usr/share/man/man8/pam_abl.8"
+ install --mode=0644 -D -- doc/pam_abl.conf.5 \
+ "$pkgdir/usr/share/man/man5/pam_abl.conf.5"
+}
+
+
diff --git a/pam_abl.install b/pam_abl.install
new file mode 100644
index 000000000000..6f207b3c0672
--- /dev/null
+++ b/pam_abl.install
@@ -0,0 +1,11 @@
+post_upgrade() {
+ echo Warning: the database format has changed with version 0.5.0.
+ echo The database files must be manually deleted and recreated if
+ echo you are upgrading from an earlier version.
+}
+
+post_install() {
+ echo This package requires non-trivial configuration. See the
+ echo Arch Wiki for details:
+ echo https://wiki.archlinux.org/index.php/Pam_abl
+}