summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Bessonov2019-04-25 12:08:45 +0400
committerVictor Bessonov2019-04-25 12:08:45 +0400
commit30a3b9e3ef8b631919e99ee62dd783848b728a52 (patch)
tree0deef8c3d91ad45612e2ec19ecc2731462e16287
parent8388c8003245434f01d96fcc52f880302dd32575 (diff)
downloadaur-30a3b9e3ef8b631919e99ee62dd783848b728a52.tar.gz
Bump
-rw-r--r--PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0585e2312c13..0a816f8cea37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,17 @@
-# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
-# Contributor: William Rea <sillywilly@gmail.com>
pkgname=pam_p11
-pkgver=0.1.5
+pkgver=0.3.0
pkgrel=1
pkgdesc="PAM module for using crpytographic tokens such as smart cards and usb crypto tokens for authentication"
-url="http://www.opensc-project.org/pam_p11"
+url="https://github.com/OpenSC/pam_p11"
arch=('x86_64' 'i686')
license=('LGPL')
-depends=('pam' 'libp11' 'openssl')
-source=("http://downloads.sourceforge.net/project/opensc/pam_p11/$pkgname-$pkgver.tar.gz"
- "pam_symbols.ver")
-sha256sums=('74da875467c4ba156f7cb7eaec0718f92dded03f40db3c6c0423c03f44d9f25a'
- '3359a9186617879479a4e943a16bc8c69e4d0ab259e6b729f983ca9328616756')
+depends=('pkgconf' 'openssl' 'libp11' 'pam' )
+source=("https://github.com/OpenSC/pam_p11/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('7b48dc8750af11e16a1a16e7bb775804b5eae4c4b123c24377d6975731da4552')
build() {
- # Taken from Gentoo ebuild
- LDFLAGS="$LDFLAGS -Wl,--version-script=$srcdir/pam_symbols.ver"
cd "$pkgname-$pkgver"
- ./configure --prefix=/usr --libdir=/lib --disable-static
+ ./configure --prefix=/usr --libdir=/lib
make
}