summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Scarpino2015-08-05 19:02:50 +0200
committerAndrea Scarpino2015-08-05 19:02:50 +0200
commitf4bf21c8b1ce3f426942f5da7e71ed043d4c9388 (patch)
tree0f59f1302c2d2e16338860c691209bb471c8de1a
parentabe30e901fc0d1468421e491b3de19b5706ff784 (diff)
downloadaur-f4bf21c8b1ce3f426942f5da7e71ed043d4c9388.tar.gz
Update to 0.6.8
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 488c1d9fa8e7..d434f1fd43ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,30 @@
# Contributor: Oleg Smirnov <oleg.smirnov@gmail.com>
pkgname=pam_pkcs11
-pkgver=0.6.6
+pkgver=0.6.8
pkgrel=1
-pkgdesc="PAM module allows a X.509 certificate based user login"
+pkgdesc='PAM module allows a X.509 certificate based user login'
arch=('i686' 'x86_64')
-url="http://www.opensc-project.org/pam_pkcs11/"
+url='https://www.opensc-project.org/opensc/wiki/pam_pkcs11'
license=('LGPL')
depends=('pcsclite')
backup=('etc/pam_pkcs11/pam_pkcs11.conf' 'etc/pam_pkcs11/subject_mapping' 'etc/pam_pkcs11/card_eventmgr.conf')
-source=("https://github.com/OpenSC/pam_pkcs11/archive/${pkgname}-${pkgver}.tar.gz")
-md5sums=('12eeccb422fd6e99cb46fa72466c7174')
+source=("https://www.opensc-project.org/svnp/files/trunk/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('5ca42826b60ffcb574cc16b965f56b00')
build() {
- cd ${pkgname}-${pkgname}-$pkgver
- ./bootstrap
+ cd ${pkgname}-$pkgver
./configure --prefix=/usr \
--sysconfdir=/etc \
--with-ldap=no \
--without-docbook \
--disable-static
-# --disable-debug, the build is broken
+# --disable-debug # build is broken
make
}
package() {
- cd ${pkgname}-${pkgname}-$pkgver
+ cd ${pkgname}-$pkgver
make DESTDIR="${pkgdir}" install
install -d "${pkgdir}"/etc/pam_pkcs11/{cacerts,crls}