summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpancho horrillo2020-11-13 06:26:02 +0100
committerpancho horrillo2020-11-13 06:57:30 +0100
commit0ec4a77bdc2573a22bcd62c50ffe5869195489e1 (patch)
treeb6176c6d2635bf878cf870e817642f9585475953
parentcb4ed823ece6b3316a7b4103135dec8d1711473c (diff)
downloadaur-pam_ssh.tar.gz
Fix GCC10 incompatibility via patch, drop old code
Thanks a bunch to Jerome Benoît, who kindly let me know¹ that the GCC10 incompatibility issue had been fixed² by Jeroen Roovers jer@gentoo.org at Gentoo. I've applied the patch² and removed the relaxing parameter to GCC. Also, I've dropped the install script, which at this point is ancient history. Fix indent style for sha512sums array. ¹: https://sourceforge.net/p/pam-ssh/bugs/18/#e743 ²: https://709312.bugs.gentoo.org/attachment.cgi?id=634046
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
-rw-r--r--pam_ssh.install78
3 files changed, 13 insertions, 84 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa3e2b412cf4..ce8cc3a91cf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = pam_ssh
pkgdesc = PAM module providing single sign-on behavior for SSH.
pkgver = 2.3
- pkgrel = 2
+ pkgrel = 3
url = http://pam-ssh.sourceforge.net/
- install = pam_ssh.install
arch = i686
arch = x86_64
license = custom
@@ -11,9 +10,11 @@ pkgbase = pam_ssh
depends = openssl
depends = openssh
options = !libtool
+ source = fix-common.patch::https://709312.bugs.gentoo.org/attachment.cgi?id=634046
source = https://sourceforge.net/projects/pam-ssh/files/pam_ssh/2.3/pam_ssh-2.3.tar.xz
source = https://sourceforge.net/projects/pam-ssh/files/pam_ssh/2.3/pam_ssh-2.3.tar.xz.asc
validpgpkeys = 501B088D8485568B87BB62BE180F6A5B3EDE742E
+ sha512sums = 064036f99f88c142d585b0825bf6c20d10d40fb1ca06ad09be51804fd49cb2dfcbee7633a9ae5237e54b0c9aa20b2ef687fea2fa883e3022b352c78c25fc4d3f
sha512sums = e3ddcf851ffd8f6fb831e2dee7269c1b89283ae2f8f6aa3487bf7b1bc71d26ac9bcbd2a01c5a67a983b980bbb5151e991402940f4752741286d057843c817895
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 03aaf0ce41ec..31e6abe51241 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,32 @@
pkgname=pam_ssh
pkgver=2.3
-pkgrel=2
+pkgrel=3
pkgdesc='PAM module providing single sign-on behavior for SSH.'
arch=('i686' 'x86_64')
url='http://pam-ssh.sourceforge.net/'
license=('custom')
depends=('pam' 'openssl' 'openssh')
options=('!libtool')
-install="$pkgname.install"
source=(
+ "fix-common.patch::https://709312.bugs.gentoo.org/attachment.cgi?id=634046"
"https://sourceforge.net/projects/pam-ssh/files/pam_ssh/$pkgver/pam_ssh-$pkgver.tar.xz"{,.asc}
)
-sha512sums=('e3ddcf851ffd8f6fb831e2dee7269c1b89283ae2f8f6aa3487bf7b1bc71d26ac9bcbd2a01c5a67a983b980bbb5151e991402940f4752741286d057843c817895'
+sha512sums=('064036f99f88c142d585b0825bf6c20d10d40fb1ca06ad09be51804fd49cb2dfcbee7633a9ae5237e54b0c9aa20b2ef687fea2fa883e3022b352c78c25fc4d3f'
+ 'e3ddcf851ffd8f6fb831e2dee7269c1b89283ae2f8f6aa3487bf7b1bc71d26ac9bcbd2a01c5a67a983b980bbb5151e991402940f4752741286d057843c817895'
'SKIP')
validpgpkeys=(
'501B088D8485568B87BB62BE180F6A5B3EDE742E' # Wolfgang Rosenauer
)
+prepare () {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < "$srcdir/fix-common.patch"
+}
+
build () {
cd "$srcdir/$pkgname-$pkgver"
- CFLAGS="$CFLAGS -fcommon" ./configure --prefix=/usr --with-pam-dir=/usr/lib/security
+ ./configure --prefix=/usr --with-pam-dir=/usr/lib/security
make
}
diff --git a/pam_ssh.install b/pam_ssh.install
deleted file mode 100644
index a6486e1486f7..000000000000
--- a/pam_ssh.install
+++ /dev/null
@@ -1,78 +0,0 @@
-_define () {
- read -r -d '' ${1} || true
-}
-
-_define _CAVEAT_PRE_2_0 <<-'EOF'
-
- CAVEAT EMPTOR: Backward incompatible change, requires manual intervention:
-
- (See the abridged README and Changelog below).
-
- To sum up:
- . The "keyfiles" option has been removed. You should edit your /etc/pam.d/???
- and remove it.
-
- . If ~/.ssh/id_(ed25519|(r|d|ecd)sa) exist, those will be used.
-
- . The module now also tries to authenticate against keys located in
- ~/.ssh/login-keys.d/ (can be symlinks to the actual keys).
-
- . Additional keys in ~/.ssh/session-keys.d/ will be loaded too.
-
-
-
- Excerpt from pam_ssh 2.0 README:
-
- Per-user setup
- --------------
-
- pam_ssh will try to decrypt the traditional SSH keys, that is, files
- matching $HOME/.ssh/id_(ed25519|(r|d|ecd)sa). pam_ssh will also try to
- decrypt all keys in the directories $HOME/.ssh/login-keys.d and
- $HOME/.ssh/session-keys.d, and (if your system administrator has
- configured your system thus) allow you to log in using any of these login
- keys. So if you want to log in by using an SSH key passphrase, you should
- create a login-keys.d directory and in this directory create (symbolic
- links to) all the keys you want to use as login keys. Nevertheless keys
- in the directory $HOME/.ssh/login-keys.d with .disabled or .frozen as
- suffix are ignored. The handling for keys in $HOME/.ssh/session-keys.d
- is similar bot those are not used for login purposes.
-
-
- Excerpt from pam_ssh 2.0 Changelog:
-
- Version 2.0 released
- ====================
-
- 2013-11-17 Wolfgang Rosenauer
-
- * pam_ssh.c: search additional keys in directory session-keys.d
- Users having alternative keys (non-default names) and want them
- unlocked at login with the passphrase and added to the agent
- can now put or link them into .ssh/session-keys.d directory
-
-
- 2013-11-10 Wolfgang Rosenauer
-
- [...]
- * pam_get_pass.c, pam_get_pass.h, pam_ssh.c:
- [...]
- Look for SSH keys in $HOME/.ssh/login-keys.d/, given that SSH keys
- with .disabled or .frozen as suffix are ignored.
- "keyfiles" option has been removed
-EOF
-
-_is_older_than_2_0 () {
- local pkg_ver="$1"
-
- test $(vercmp "$pkg_ver" '2.0') -lt 0
-}
-
-post_upgrade () {
- local new_pkg_ver="$1" # not used
- local old_pkg_ver="$2"
-
- if _is_older_than_2_0 $old_pkg_ver; then
- echo "$_CAVEAT_PRE_2_0"
- fi
-}