summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpancho horrillo2019-02-05 20:01:38 +0100
committerpancho horrillo2019-02-05 20:01:38 +0100
commiteed07623825bf13f642db42d8bef6f4e65325636 (patch)
tree3e478adf3a8c0ac38d6f212506d21a965b5db6a8
parente42f0e0b06181c5b721b0b1041fde1f739fcef87 (diff)
downloadaur-eed07623825bf13f642db42d8bef6f4e65325636.tar.gz
Update to pam_ssh 2.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
-rw-r--r--pam_ssh.install4
3 files changed, 22 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f74f1876a65..010876d532ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
# Generated by mksrcinfo v8
-# Wed May 9 18:59:10 UTC 2018
+# Tue Feb 5 18:58:23 UTC 2019
pkgbase = pam_ssh
pkgdesc = PAM module providing single sign-on behavior for SSH.
- pkgver = 2.1
- pkgrel = 5
+ pkgver = 2.3
+ pkgrel = 1
url = http://pam-ssh.sourceforge.net/
install = pam_ssh.install
arch = i686
arch = x86_64
license = custom
depends = pam
- depends = openssl-1.0
+ depends = openssl
depends = openssh
options = !libtool
- source = https://sourceforge.net/projects/pam-ssh/files/pam_ssh/2.1/pam_ssh-2.1.tar.xz
- source = https://sourceforge.net/projects/pam-ssh/files/pam_ssh/2.1/pam_ssh-2.1.tar.xz.asc
- sha512sums = 8252b15efffa5687f740963f7a3c3479b73f99eca26a17155f915a10b9a71362a2778449adf10f01c174cc8545961ce3ea64459338a7c995c242b209529fd640
+ source = https://sourceforge.net/projects/pam-ssh/files/pam_ssh/2.3/pam_ssh-2.3.tar.xz
+ source = https://sourceforge.net/projects/pam-ssh/files/pam_ssh/2.3/pam_ssh-2.3.tar.xz.asc
+ sha512sums = e3ddcf851ffd8f6fb831e2dee7269c1b89283ae2f8f6aa3487bf7b1bc71d26ac9bcbd2a01c5a67a983b980bbb5151e991402940f4752741286d057843c817895
sha512sums = SKIP
pkgname = pam_ssh
diff --git a/PKGBUILD b/PKGBUILD
index 71bbf89eea32..bb73b6726784 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,32 @@
# Contributor: Troels Kofoed Jacobsen <tkjacobsen at gmail dot com>
pkgname=pam_ssh
-pkgver=2.1
-pkgrel=5
+pkgver=2.3
+pkgrel=1
pkgdesc='PAM module providing single sign-on behavior for SSH.'
arch=('i686' 'x86_64')
url='http://pam-ssh.sourceforge.net/'
license=('custom')
-depends=('pam' 'openssl-1.0' 'openssh')
+depends=('pam' 'openssl' 'openssh')
options=('!libtool')
install="$pkgname.install"
source=(
- "https://sourceforge.net/projects/pam-ssh/files/pam_ssh/2.1/pam_ssh-2.1.tar.xz"{,.asc}
-)
-sha512sums=(
- '8252b15efffa5687f740963f7a3c3479b73f99eca26a17155f915a10b9a71362a2778449adf10f01c174cc8545961ce3ea64459338a7c995c242b209529fd640'
- 'SKIP'
+ "https://sourceforge.net/projects/pam-ssh/files/pam_ssh/$pkgver/pam_ssh-$pkgver.tar.xz"{,.asc}
)
+sha512sums=('e3ddcf851ffd8f6fb831e2dee7269c1b89283ae2f8f6aa3487bf7b1bc71d26ac9bcbd2a01c5a67a983b980bbb5151e991402940f4752741286d057843c817895'
+ 'SKIP')
validpgpkeys=(
- '501B088D8485568B87BB62BE180F6A5B3EDE742E' # Wolfgang Rosenauer
+ '501B088D8485568B87BB62BE180F6A5B3EDE742E' # Wolfgang Rosenauer
)
build () {
- cd "$srcdir/$pkgname-$pkgver"
- CPPFLAGS+=' -I /usr/include/openssl-1.0' ./configure --prefix=/usr --with-pam-dir=/usr/lib/security --with-ssl-dir=/usr/lib/openssl-1.0
- make
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --with-pam-dir=/usr/lib/security
+ make
}
package () {
- cd "$srcdir/$pkgname-$pkgver"
- CPPFLAGS+=' -I /usr/include/openssl-1.0' make DESTDIR="$pkgdir" install
- install -m 644 -D COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -m 644 -D COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
diff --git a/pam_ssh.install b/pam_ssh.install
index 3862bd64f718..a6486e1486f7 100644
--- a/pam_ssh.install
+++ b/pam_ssh.install
@@ -12,7 +12,7 @@ _define _CAVEAT_PRE_2_0 <<-'EOF'
. The "keyfiles" option has been removed. You should edit your /etc/pam.d/???
and remove it.
- . If ~/.ssh/id(entity|_(r|d|ecd)sa) exist, those will be used.
+ . If ~/.ssh/id_(ed25519|(r|d|ecd)sa) exist, those will be used.
. The module now also tries to authenticate against keys located in
~/.ssh/login-keys.d/ (can be symlinks to the actual keys).
@@ -27,7 +27,7 @@ _define _CAVEAT_PRE_2_0 <<-'EOF'
--------------
pam_ssh will try to decrypt the traditional SSH keys, that is, files
- matching $HOME/.ssh/id(entity|_(r|d|ecd)sa). pam_ssh will also try to
+ matching $HOME/.ssh/id_(ed25519|(r|d|ecd)sa). pam_ssh will also try to
decrypt all keys in the directories $HOME/.ssh/login-keys.d and
$HOME/.ssh/session-keys.d, and (if your system administrator has
configured your system thus) allow you to log in using any of these login