summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiccolò Maggioni2015-07-23 23:17:11 +0200
committerNiccolò Maggioni2015-07-23 23:18:21 +0200
commit5bb2106a5bc6b089f2709c114f198813f921e618 (patch)
tree35e993d6d9083db8cb1c61f9f08780e11026a51c
downloadaur-5bb2106a5bc6b089f2709c114f198813f921e618.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD35
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ccabec0431f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = pam_u2f-git
+ pkgdesc = Universal 2nd Factor (U2F) PAM authentication module from Yubico - git checkout
+ pkgver = 1.0.1.r11.gc383c0e
+ pkgrel = 1
+ url = https://developers.yubico.com/pam-u2f/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = asciidoc
+ makedepends = libxslt
+ makedepends = libxml2
+ makedepends = docbook-xml
+ makedepends = docbook-xsl
+ depends = pam
+ depends = libu2f-host
+ depends = libu2f-server
+ provides = pam_u2f
+ conflicts = pam_u2f
+ source = git://github.com/Yubico/pam-u2f.git
+ md5sums = SKIP
+
+pkgname = pam_u2f-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a59a7748265
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=pam_u2f-git
+pkgver=1.0.1.r11.gc383c0e
+pkgrel=1
+pkgdesc="Universal 2nd Factor (U2F) PAM authentication module from Yubico - git checkout"
+arch=('i686' 'x86_64')
+url='https://developers.yubico.com/pam-u2f/'
+license=('BSD')
+depends=('pam' 'libu2f-host' 'libu2f-server')
+makedepends=('git' 'autoconf' 'automake' 'asciidoc' 'libxslt' 'libxml2' 'docbook-xml' 'docbook-xsl')
+provides=('pam_u2f')
+conflicts=('pam_u2f')
+source=("git://github.com/Yubico/pam-u2f.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd pam-u2f/
+ git describe --long --tags | sed 's/^pam_u2f.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd pam-u2f/
+ autoreconf -fi
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd pam-u2f/
+ make check
+}
+
+package() {
+ cd pam-u2f/
+ make DESTDIR="${pkgdir}/usr" install
+}