summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Rodriguez2015-08-15 20:49:54 -0400
committerDavid Rodriguez2015-08-15 20:49:54 -0400
commit460a741ee2cc14756e53be09ff05d9f85ac73e71 (patch)
treed39aa7ed30f35face78de3f62bb0835cc7c44875
downloadaur-460a741ee2cc14756e53be09ff05d9f85ac73e71.tar.gz
Initial AUR4 commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b04f4bb187eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pam_usb
+ pkgdesc = PAM modules that enables either two-factor or password-less authentication using an USB storage device (such as an USB flash memory stick)
+ pkgver = 0.5.0
+ pkgrel = 4
+ url = https://github.com/aluzzardi/pam_usb
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxml2
+ depends = pam
+ depends = pmount
+ depends = udisks
+ depends = dbus-python
+ depends = pygobject
+ backup = etc/pamusb.conf
+ source = https://github.com/aluzzardi/pam_usb/archive/0.5.0.tar.gz
+ md5sums = df8404aeb625eca1d3cad7a67d35f225
+
+pkgname = pam_usb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d79c29553c5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: David Rodriguez <dissonant.tech@gmail.com>
+
+pkgname=pam_usb
+pkgver=0.5.0
+pkgrel=4
+pkgdesc="PAM modules that enables either two-factor or password-less authentication using an USB storage device (such as an USB flash memory stick)"
+url="https://github.com/aluzzardi/pam_usb"
+license=("GPL")
+depends=(libxml2 pam pmount udisks dbus-python pygobject)
+arch=('i686' 'x86_64')
+backup=('etc/pamusb.conf')
+md5sums=('df8404aeb625eca1d3cad7a67d35f225')
+source=(https://github.com/aluzzardi/$pkgname/archive/$pkgver.tar.gz)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make LIBS="`pkg-config --libs libxml-2.0` `pkg-config --libs dbus-1` -lpam" || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" PAM_USB_DEST="$pkgdir/usr/lib/security" install
+ sed -i 1s/python/python2/ "$pkgdir/usr/bin/pamusb-"{agent,conf}
+}