summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2021-03-20 16:01:06 +0100
committerFrederic Bezies2021-03-20 16:01:06 +0100
commit96a5b65f2e9f05588cd4e951ef5e9ec461c74b35 (patch)
tree50f8186d98c512289e568938b64d5776a9835639
parent4ab876adc4c85c338865709410fe27807a3c3b61 (diff)
downloadaur-96a5b65f2e9f05588cd4e951ef5e9ec461c74b35.tar.gz
March 20th, 2021 update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--build.patch71
3 files changed, 79 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1837b5b06ac7..9c65fcefadaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pamac-all
pkgdesc = A Gtk3 frontend for libalpm (everything in one package - snap, flatpak, appindicator)
pkgver = 10.0.5
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.manjaro.org/applications/pamac
install = pamac.install
arch = i686
@@ -57,7 +57,9 @@ pkgbase = pamac-all
options = !emptydirs
backup = etc/pamac.conf
source = pamac-10.0.5.tar.gz::https://gitlab.manjaro.org/applications/pamac/-/archive/v10.0.5/pamac-v10.0.5.tar.gz
+ source = build.patch
sha256sums = 3650d0a2d9633d27ee465ecaaaf33fa1255b4d44d1034433b2a2f16d963521b0
+ sha256sums = bcb9c3cafac802342cb597dadbe6d0384a3c8b2e462bbc46464fbf9c4c7497c7
pkgname = pamac-all
diff --git a/PKGBUILD b/PKGBUILD
index 8fbeb36ae83b..a216d91952f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ ENABLE_GNOME=0
pkgname=pamac-all
pkgver=10.0.5
-pkgrel=1
+pkgrel=2
_pkgfixver=$pkgver
pkgdesc="A Gtk3 frontend for libalpm (everything in one package - snap, flatpak, appindicator)"
@@ -27,9 +27,10 @@ options=(!emptydirs)
install=pamac.install
source=(
"pamac-$pkgver.tar.gz::$url/-/archive/v$pkgver/pamac-v$pkgver.tar.gz"
-# "https://gitlab.manjaro.org/applications/pamac/-/commit/83ac80d7.patch"
+ "build.patch"
)
-sha256sums=('3650d0a2d9633d27ee465ecaaaf33fa1255b4d44d1034433b2a2f16d963521b0')
+sha256sums=('3650d0a2d9633d27ee465ecaaaf33fa1255b4d44d1034433b2a2f16d963521b0'
+ 'bcb9c3cafac802342cb597dadbe6d0384a3c8b2e462bbc46464fbf9c4c7497c7')
define_meson=''
if [ "${ENABLE_FLATPAK}" = 1 ]; then
depends+=('flatpak')
@@ -62,6 +63,7 @@ prepare() {
cd "$srcdir/pamac-v$pkgver"
# adjust version string
sed -i -e "s|\"$_pkgfixver\"|\"$pkgver-$pkgrel\"|g" src/version.vala
+ patch -Np1 < ../build.patch
}
build() {
diff --git a/build.patch b/build.patch
new file mode 100644
index 000000000000..c2c84bf0f245
--- /dev/null
+++ b/build.patch
@@ -0,0 +1,71 @@
+diff --git a/src/alpm_package.vala b/src/alpm_package.vala
+index 9d3894cafe5185eb38d6cdaa81bcd9b9910d407f..5557e359956b8798bd27213f625bb437008b51c6 100644
+--- a/src/alpm_package.vala
++++ b/src/alpm_package.vala
+@@ -443,7 +443,7 @@ namespace Pamac {
+ Alpm.List<string> owned_list = local_pkg.compute_requiredby ();
+ unowned Alpm.List<string> list = owned_list;
+ while (list != null) {
+- _requiredby.add ((owned) list.data);
++ _requiredby.add (list.data);
+ list.next ();
+ }
+ }
+@@ -459,7 +459,7 @@ namespace Pamac {
+ Alpm.List<string> owned_list = local_pkg.compute_optionalfor ();
+ unowned Alpm.List<string> list = owned_list;
+ while (list != null) {
+- _optionalfor.add ((owned) list.data);
++ _optionalfor.add (list.data);
+ list.next ();
+ }
+ }
+@@ -1093,7 +1093,7 @@ namespace Pamac {
+ Alpm.List<string> owned_list = local_pkg.compute_requiredby ();
+ unowned Alpm.List<string> list = owned_list;
+ while (list != null) {
+- _requiredby.add ((owned) list.data);
++ _requiredby.add (list.data);
+ list.next ();
+ }
+ }
+@@ -1109,7 +1109,7 @@ namespace Pamac {
+ Alpm.List<string> owned_list = local_pkg.compute_optionalfor ();
+ unowned Alpm.List<string> list = owned_list;
+ while (list != null) {
+- _optionalfor.add ((owned) list.data);
++ _optionalfor.add (list.data);
+ list.next ();
+ }
+ }
+diff --git a/src/alpm_utils.vala b/src/alpm_utils.vala
+index 784e1dd1779d7d9b760fef530ccc8fe3bb3d4c72..8baca55e8aeeb3e492d764f66c4884f62b537221 100644
+--- a/src/alpm_utils.vala
++++ b/src/alpm_utils.vala
+@@ -1487,7 +1487,7 @@ namespace Pamac {
+ if (pkg_to_add_name == requiredby_list.data) {
+ if (pkg_to_add_name in to_build) {
+ // found the top requiredby package
+- pkg.requiredby.add ((owned) requiredby_list.data);
++ pkg.requiredby.add (requiredby_list.data);
+ dep_found = true;
+ } else {
+ if (pkg_to_add_name in checked) {
+@@ -1543,7 +1543,7 @@ namespace Pamac {
+ if (pkg_to_add_name in to_install
+ || pkg_to_add_name in to_build) {
+ // found the top requiredby package
+- pkg.requiredby.add ((owned) requiredby_list.data);
++ pkg.requiredby.add (requiredby_list.data);
+ dep_found = true;
+ } else {
+ if (pkg_to_add_name in checked) {
+@@ -1653,7 +1653,7 @@ namespace Pamac {
+ unowned string name = requiredby.data;
+ if (name in to_remove) {
+ // found the top requiredby package
+- pkg.requiredby.add ((owned) requiredby.data);
++ pkg.requiredby.add (requiredby.data);
+ dep_found = true;
+ } else {
+ // check name requiredby