summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2018-03-28 22:16:06 +0200
committerFrederic Bezies2018-03-28 22:16:06 +0200
commit4272ce53c2333c105a14464c0f03a1d23a8f4c69 (patch)
tree4c8d6f58be3372866b20dc9bd57567843a3c2659
parent2f255e0348e45322eac05d3459ef02ac7c4d6ae7 (diff)
downloadaur-4272ce53c2333c105a14464c0f03a1d23a8f4c69.tar.gz
systemd timer fix
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rw-r--r--pamac.install10
3 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fb1880ee40c..430ab58a2ed3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pamac-aur-git
pkgdesc = A Gtk3 frontend for libalpm - git version
pkgver = v6.2.6.r1.g2370068
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/manjaro/pamac
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index f5e5a4ce306c..b7868533a700 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=('pamac-aur-git' 'pamac-aur-tray-appindicator-git')
_pkgname=pamac
pkgver=v6.2.6.r1.g2370068
_pkgver=6.2.6
-pkgrel=3
+pkgrel=4
pkgdesc="A Gtk3 frontend for libalpm - git version"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/manjaro/pamac"
@@ -51,9 +51,6 @@ package_pamac-aur-git() {
cd "$_pkgname"
cd builddir
DESTDIR="$pkgdir" ninja install
- # enable systemd timer
- mkdir -p "$pkgdir/etc/systemd/system/multi-user.target.wants"
- ln -sf "/usr/lib/systemd/system/pamac-cleancache.timer" "$pkgdir/etc/systemd/system/multi-user.target.wants"
# removed pamac-mirrorlist-timer, useless for Archlinux
# remove pamac-tray-appindicator
rm "$pkgdir/usr/bin/pamac-tray-appindicator"
diff --git a/pamac.install b/pamac.install
index 471206c11b1a..735605944888 100644
--- a/pamac.install
+++ b/pamac.install
@@ -1,7 +1,17 @@
post_install() {
+ # enable systemd timers
+ ln -sf /usr/lib/systemd/system/pamac-cleancache.timer /etc/systemd/system/multi-user.target.wants
+ ln -sf /usr/lib/systemd/system/pamac-mirrorlist.timer /etc/systemd/system/multi-user.target.wants
+ # polkit agent
printf '==> An authentication agent is required\n'
printf ' Cinnamon, Deepin, GNOME, GNOME Flashback, KDE, LXDE, LXQt, MATE and Xfce\n'
printf ' have an authentication agent already.\n'
printf ' See https://wiki.archlinux.org/index.php/Polkit#Authentication_agents\n'
printf ' for other desktop environments.\n'
}
+
+post_remove() {
+ # disable systemd timers
+ rm -f /etc/systemd/system/multi-user.target.wants/pamac-cleancache.timer
+ rm -f /etc/systemd/system/multi-user.target.wants/pamac-mirrorlist.timer
+}