summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTommyTran7322021-08-18 03:22:00 -0400
committerTommyTran7322021-08-18 03:22:00 -0400
commitd9755bdb571ea84809a980b91455415a79b2f376 (patch)
treeb28e9fc374d56b3b2b4b9b73c710ea9ec3fca9fa
downloadaur-d9755bdb571ea84809a980b91455415a79b2f376.tar.gz
Initial Commit
-rw-r--r--.SRCINFO39
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD48
-rw-r--r--README.md9
-rw-r--r--pamac.install22
5 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b5dfe26e9a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = pamac-flatpak
+ pkgdesc = A Gtk3 frontend for libalpm (with AUR, Flatpak and AppIndicator support)
+ pkgver = 10.1.3
+ pkgrel = 3
+ url = https://gitlab.manjaro.org/applications/pamac
+ install = pamac.install
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = gettext
+ makedepends = itstool
+ makedepends = vala>=0.45
+ makedepends = meson
+ makedepends = ninja
+ makedepends = gobject-introspection
+ makedepends = xorgproto
+ makedepends = asciidoc
+ depends = libnotify
+ depends = libpamac-flatpak
+ depends = libhandy
+ depends = libappindicator-gtk3
+ optdepends = polkit-gnome: needed for authentification in Cinnamon, Gnome
+ provides = pamac
+ conflicts = pamac
+ conflicts = pamac-cli
+ conflicts = pamac-classic
+ conflicts = pamac-aur
+ conflicts = pamac-aur-git
+ conflicts = pamac-all
+ conflicts = pamac-all-git
+ options = !emptydirs
+ source = pamac-10.1.3.tar.gz::https://gitlab.manjaro.org/applications/pamac/-/archive/v10.1.3/pamac-v10.1.3.tar.gz
+ sha256sums = 577c0dfca155af9f4a7537b6c09bd37958ea5b5724c187f03239b27bd3d5951a
+
+pkgname = pamac-flatpak \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..fdddb29aa445
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <https://unlicense.org>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f324cfb3ff9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: TommyTran732
+# https://gitlab.manjaro.org/packages/extra/pamac
+
+#Set this flag to 0 if you want to use pamac-tray-icon-plasma
+ENABLE_APPINDICATOR=1
+
+pkgname=pamac-flatpak
+pkgver=10.1.3
+pkgrel=3
+_pkgfixver=$pkgver
+
+pkgdesc="A Gtk3 frontend for libalpm (with AUR, Flatpak and AppIndicator support)"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://gitlab.manjaro.org/applications/pamac"
+license=('GPL3')
+depends=('libnotify' 'libpamac-flatpak' 'libhandy')
+optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome')
+makedepends=('gettext' 'itstool' 'vala>=0.45' 'meson' 'ninja' 'gobject-introspection' 'xorgproto' 'asciidoc')
+conflicts=('pamac' 'pamac-cli' 'pamac-classic' 'pamac-aur' 'pamac-aur-git' 'pamac-all' 'pamac-all-git' 'pamac-flatpak-gnome')
+provides=('pamac')
+options=(!emptydirs)
+install=pamac.install
+source=("pamac-$pkgver.tar.gz::$url/-/archive/v$pkgver/pamac-v$pkgver.tar.gz")
+sha256sums=('577c0dfca155af9f4a7537b6c09bd37958ea5b5724c187f03239b27bd3d5951a')
+
+if [ "${ENABLE_APPINDICATOR}" = 1 ]; then
+ depends+=('libappindicator-gtk3')
+ define_meson+=' -Denable-appindicator=true'
+fi
+
+prepare() {
+ cd "$srcdir/pamac-v$pkgver"
+ # adjust version string
+ sed -i -e "s|\"$_pkgfixver\"|\"$pkgver-$pkgrel\"|g" src/version.vala
+}
+
+build() {
+ cd "$srcdir/pamac-v$pkgver"
+ mkdir -p builddir
+ cd builddir
+ meson --prefix=/usr --sysconfdir=/etc -Denable-flatpak=true $define_meson --buildtype=release
+ ninja
+}
+
+package() {
+ cd "$srcdir/pamac-v$pkgver/builddir"
+ DESTDIR="$pkgdir" ninja install
+} \ No newline at end of file
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..c70efc4d6b61
--- /dev/null
+++ b/README.md
@@ -0,0 +1,9 @@
+# pamac-flatpak
+A Gtk3 frontend for libalpm (with AUR, Flatpak and AppIndicator support)
+
+# Attribution
+This package is a modified version of [pamac-all](https://aur.archlinux.org/packages/pamac-all) with Snapd removed. <br >
+
+# Notes
+The Flathub Beta repository is enable by default. <br >
+I have also removed the post_upgrade() function to make it so that if you remove any of the default Flatpak repo, they won't persistently come back after an update. \ No newline at end of file
diff --git a/pamac.install b/pamac.install
new file mode 100644
index 000000000000..4912c8eb1263
--- /dev/null
+++ b/pamac.install
@@ -0,0 +1,22 @@
+post_install() {
+ # enable flatpak repo
+ if [ -f /usr/bin/flatpak ]; then
+ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
+ flatpak remote-add --if-not-exists flathub-beta https://flathub.org/repo-beta/flathub-beta.flatpakrepo
+ fi
+ # enable systemd timers
+ ln -sf /usr/lib/systemd/system/pamac-cleancache.timer /etc/systemd/system/multi-user.target.wants
+ #ln -sf /usr/lib/systemd/system/pamac-mirrorlist.timer /etc/systemd/system/multi-user.target.wants
+ # polkit agent
+ printf '==> An authentication agent is required\n'
+ printf ' Cinnamon, Deepin, GNOME, GNOME Flashback, KDE, LXDE, LXQt, MATE and Xfce\n'
+ printf ' have an authentication agent already.\n'
+ printf ' See https://wiki.archlinux.org/index.php/Polkit#Authentication_agents\n'
+ printf ' for other desktop environments.\n'
+}
+
+post_remove() {
+ # disable systemd timers
+ rm -f /etc/systemd/system/multi-user.target.wants/pamac-cleancache.timer
+ #rm -f /etc/systemd/system/multi-user.target.wants/pamac-mirrorlist.timer
+}