summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDidier Richard2020-12-28 11:33:41 +0100
committerDidier Richard2020-12-28 11:33:41 +0100
commit94c68a0e794b89a5754f649c36c37bddf2a6d298 (patch)
tree68ddeb7c5693b3b15ff72720c64afc2927659dac
downloadaur-94c68a0e794b89a5754f649c36c37bddf2a6d298.tar.gz
First AUR Release
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD40
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1f5634e3b3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pamac-tray-icon-plasma
+ pkgdesc = Pamac tray icon for plasma users
+ pkgver = 0.1.2
+ pkgrel = 2
+ url = https://gitlab.com/LordTermor/pamac-tray-icon-plasma
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = pamac>=10.0.2
+ depends = qt5-base>=5.15.0
+ depends = knotifications
+ conflicts = pamac-tray-appindicator
+ replaces = pamac-tray-appindicator
+ options = !emptydirs
+ source = pamac-tray-icon-plasma-0.1.2-2.tar.gz::https://gitlab.com/LordTermor/pamac-tray-icon-plasma/-/archive/4c1d846750741b60239d4f5865d5bab987604611/pamac-tray-icon-plasma-4c1d846750741b60239d4f5865d5bab987604611.tar.gz
+ sha256sums = 41e897d5e7fb0757f4e929de20c9a7326041a6a5d147499173999856732a2feb
+
+pkgname = pamac-tray-icon-plasma
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8661d7a8b9d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.gz
+*.tar
+*.tar.*
+/pkg/*
+/src/* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e80fc26a9485
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Zeph <zeph33@gmail.com>
+# Maintainer: Artyom Grinyov (LordTermor)
+# Maintainer: Zorin Arch (ZorinArch)
+
+pkgname=pamac-tray-icon-plasma
+pkgver=0.1.2
+pkgrel=2
+_commit='4c1d846750741b60239d4f5865d5bab987604611'
+sha256sums=('41e897d5e7fb0757f4e929de20c9a7326041a6a5d147499173999856732a2feb')
+
+url="https://gitlab.com/LordTermor/$pkgname"
+
+pkgdesc="Pamac tray icon for plasma users"
+arch=('x86_64')
+license=('GPL3')
+depends=('pamac>=10.0.2' 'qt5-base>=5.15.0' 'knotifications')
+makedepends=('cmake')
+conflicts=('pamac-tray-appindicator')
+replaces=('pamac-tray-appindicator')
+options=(!emptydirs)
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/-/archive/$_commit/$pkgname-$_commit.tar.gz")
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake \
+ -DCMAKE_BUILD_TYPE="None" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ ../$pkgname-$_commit
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}
+